FANDOM


Major cleanup

I did a rather thorough testing of commands and cleanup of the page. It's probably more useful now.

Template:Notebox

/Mirar 10:47, 11 December 2008 (UTC)

Origins

I got this from http://www.gamepro.com/article/cheats/207814/fallout-3-console-codes/ , sorted it alphabetically and changed a few things. I didnt test all the commands. Conradesc 10:45, 13 November 2008 (UTC)

How do you set ownership of beds and stuff? I'm evil and I want to kill Silver and claim her house as my own.

console, click on item, 'setownership'. --ThorX 06:10, 10 May 2009 (UTC)

Thanks for quick ownership addition... "SetEssential" 1 and "setessential 6a772 1" both do not work for me, however I've had alot of console issues...

tagged skills

is there any way to edit tagged skills in the console? is there a command that can let you tag all skills, or to let have 13 tag skill allocation points at character creation? 69.196.169.208 17:40, 28 November 2008 (UTC)

AddPerk & RemovePerk

These two need more elaboration on how to use them. Were I trying to add Toughness, even after targetting myself in 3rd person, nothing happens when I type...

  • AddPerk
  • AddPerk Toughness
  • AddPerkToughness
  • AddToughness

Servius 04:19, 8 December 2008 (UTC)

Don't type "Toughness." You need to enter in the code for the perks, which can be found here. 98.226.112.109 05:49, 8 December 2008 (UTC)
Thanks, I updated the main page. Servius 13:35, 8 December 2008 (UTC)w

Placeatme

In oblivion, excessive use of the placeatme command can lead to instability... I'm not sure if this is the same in fallout 3, but I would still warn people about it. 203.91.84.7 12:18, 14 December 2008 (UTC)

  • Using the command "MarkForDelete" on a PlaceAtMe'd ref will destroy the ref once it's been disabled. --MadCat221 01:06, 27 January 2009 (UTC)
I noticed this command does not work for npc's that are placed on the map via random encounters. - Redmess 22:19, November 29, 2009 (UTC)

Add items with condition

Uh, actually the "player.additem base_id amount quality" is wrong. The "additem" command won't take the third "quality" parameter and always gives weapons/armors with 100% condition, thus the third "100" in lots of item pages is useless. The correct command should be "player.additemhealthpercent base_id amount quality." EX: "player.additemhealthpercent 80B 3 0.97" gives the player three Chinese Assault Rifles with 97% condition. Reference: http://gib.me/fallout3/functions.html

toggledebugtext... bugged?

toggledebugtext is suppose to give you information like framerate, ect, but it's not showing anywhere on the screen when I activate the command. --86.91.243.240 15:27, 31 December 2008 (UTC)

Cloning Player

I remember in Oblivion that you could clone yourself. He/She wouldn't do anything but you could kill him/her to loot all the stuff that you have in your inventor. Could it possibly be the same as Oblivions cheat "code" for it since many other commands are similar or the same. But what i want to know is, is there a command to clone yourself? --68.39.40.221 23:32, 1 January 2009 (UTC)

Well I know you can use player.placeleveledactoratme followed by the form id '7' to create a clone of the player, but that clone, from my little test attempt, has no items. --82.17.65.210 01:39, December 21, 2009 (UTC)

player.modav "energy weapons"?

what is the command to modify your energy weapon value? Kenji 03 19:14, 5 January 2009 (UTC)

Well, if you want to modify it by five, it'd be "player.modav energyweapons 5" that would change an Energy Weapons skill of 15, to a level of 20. A better way to do it is to select a number, say, 75 and type "player.forceav energyweapons 75" which gives the actual number input as the final result.Fiddlesoup 06:09, 10 January 2009 (UTC)

Incorrect AddItem code syntax

The "AddItem" code information used throughout the site is incorrect. The current syntax, "AddItem <objectID> <quantity> <health>" isn't accurate. The value listed at the "health" spot is actually a flag for making the notification message at the top-left of the screen not show when it gets added (used in scripts to cut down on message spam), and then only if the flag's value is 1 (thus the 100 value does nothing). AddItem will automatically add the weapon to the calling object at 100% health regardless.

If you're wanting to add an item with a health less than 100, then you need to use the console command "<callingref>.AddItemHealthPercent <objectID> <quantity> <health> <messagehiddenflag>". --MadCat221 01:04, 27 January 2009 (UTC)

Well, since no one else had done anything, I've changed it.Fiddlesoup 22:05, 4 February 2009 (UTC)

No hostility?

I need to make a NPC non hostile, and be able to talk to this NPC. Reason being, I killed an NPC, and I need to talk to him, but he attacks me if I use "resurrect". What do I do?

This mod worked perfectly for me after failing at using console commands like "setav agression 0", "player.SCAOnActor", and "stopcombat". --RizzleQ 15:51, 10 August 2009 (UTC)

Gameplay issues

After fooling around in console, my game is running extremely slowly. As a joke, I made a few hundred burkes and blew them up, then fought a giant Zip. I didn't save, but ever sense then Fallout 3 has been running incredibly slow on my computer, especially in VATs. Any ideas as to what's going on? --Nux Matrix 02:19, 8 February 2009 (UTC)

Uh...help? this slowness you mentioned has happened to me too, though I did NOT use the console. I think it might be some graphics glitch..or not. Is anyone with the graphics set to Low Quality having the same problem? My laptop is an HP,vista,64-bit.I have been experiencing things from horrible lag, game freezes, my laptop saying that "Fallout has stopped working", to the dreaded case of my laptop in a state between shutting down and being on for 20 minutes before I was forced to temporarily remove the battery.Any help would be gratefully accepted. --A Gamer on his Last Legs (metaphorically)

This happens to me too, unrelated to things i do (i guess), PC reboot does the trick, some super sledge might too :). It might be related to too many scripts running in the cell, donno.

Weapon & Ammo Codes

Weapons
.32 Pistol 00050F92
10mm Pistol 0001A334
10mm SMG (Sydneys "Ultra") 0006E7CC
10mm Sub Machine gun 00004321
A3-21's Plasma Rifle 0006B539
Acid Spit 000B8793
Alien Blaster 00004322
Ant's Sting 000C553E
Assault Rifle 0001FFEC
Baseball Bat 0000421C
BB Gun 000C0327
Black Bart's Bane 0006B535
Blackhawk 000303A2
Board of Education 000C310F
Bottlecap Mine 0000433A
Brass Knuckles 00004324
Breaker 000CB546
Butch's Toothpick 00078440
Buzzsaw 0003BC6F
Chinese Assault Rifle 00046BDD
Chinese Officer's Sword 0002B3CB
Chinese Pistol 00004325
Chinese Pistol (Zhu-Rong v418) 00060C2C
Clover's Cleaver 000C80B8
Col. Autumn's 10mm Pistol 0006B531
Col. Autumn's Laser Pistol 000ABBE4
Combat Knife 00004326
Combat Shotgun 00004327
Curse Breaker 000C80BB
Dart Gun 0000432A
Deathclaw Gauntlet 0000432B
Electrical Zap 00022FF1
Eugene 0006B538
Excalibat 000C80BC
Experimental MIRV 0003422B
Fat Man 0000432C
Fawkes' Super Sledge 0007843F
Fire Hydrant 00021367
Firelance 000C80BA
Fisto! 000CB601
Flamer 00078C6
Frag Grenade 00004330
Frag Mine 0000433C
GasTrap Dummy 000001F6
Gatling Laser 0000432E
Hand Laser 00018B9E
Highwayman's Friend 00078442
Hunting Rifle 00004333
Jack 000C6E5B
Knife 00004334
Laser 00050ED0
Laser Pistol 000B4178
Law Dog 0006B532
Lead Pipe 00004337
Liberty Laser 00033FE2
LibertyPrimeWeapBomb 0005932F
Lincoln's Repeater 0003C07A
Love Tap 000C80B9
Mesmeron 00004339
Mesmetron 000BF5A4
Minigun 0000433F
Mirelurk Bait Grenade 00030664
Miss Launcher 000B2644
Missile Launcher 00057E8F
Nail Board 000A01DD
Nuka-Grenade 00004342
O'Grady's Peacemaker 0007843D
Occam's Razor 000CB602
Ol' Painless 00066C76
Plasma Grenade 00004332
Plasma Gun 0007C10C
Plasma Mine 0000433D
Plasma Pistol 00004343
Plasma Rifle 00004344
Plunkett's Valid Points 000CAFA9
Police Batton 00004345
Pool Cue 00004346
Power Fist 00004347
Protectron's Gaze 000C553F
Pulse Grenade 00004331
Pulse Mine 0000433E
Radioactive Spit 00058717
Railway Rifle 00004348
Repellent Stick 0002D3B7
Reservist's Rifle 00092966
Ripper 00004349
Rock-it launcher 0000434B
Rolling Pin 00029769
Rolling Pin 000B2943
Sawed-Off Shotgun 0000434C
Scoped .44 Magnum 0000434D
SentryBot Laser Gatling 000389AF
SentryBot Minigun 00057E8E
Shishkebab 0000434E
Shriek 0007F598
Silenced 10mm Pistol 00004350
Slasher Knife 0002869C
Sledge Hammer 00004351
Sledgehammer 00063FA2
Smuglers End (Laser Pistol) 0006B536
Sniper Rifle 00004353
Spiked Knuckels 00004354
Stabhappy 000C80BE
Super Sledge 000B0E7C
Sydney's 10mm "Ultra" SMG 0005DEEE
The Break 00066C77
The Kneecapper 0006B53A
The Shocker 000BFF62
The Tenderizer 000A874B
The Terrible Shotgun 0006B534
Tire Iron 00004328
Vampire's Edge 00078441
Vertibird Bomb Gun 0003E5E2
Vertibird Gun 00089C51
Victory Rifle 000CB548
Ammo
.308 Caliber Round 0006B53C
.32 Caliber Round 000207F7
.44 Round Magnum 0002937E
10mm Round 00004241
5.56mm Round 00078CC4
5.56mm Round 00004240
5mm Round 0006B53D
5mm Round 000615A8
Alien Powercell 00029364
BB - Ammo 0002935B
Bottlecap Mines 0000433A
Dart 00047419
Dart 0002936E
Electron Charge Pack 000615AF
Electron Charge Pack 0006B53E
Energy Cell 00020772
Energy Cell 00078CC2
Flamer Fuel 00029371
Flamer Fuel 00078CC1
Frag Grenades 00004330
Frag Mines 0000433C
Mesmetron Power Cell 0006A80D
Microfusion Cell 00078CC3
Microfusion Cell 00004485
Mini Nuke 00020799
Missile 000B8791
Missile 0005F706
Missile 00078CC5
Missles 00029383
Pulse Grenades 00004331
Railway Spikes 00029384
Shotgun Shell 00028EEA
Shotgun Shell 0004C5F9
Sonic Energy 00056634

Finding IDs

I just felt like testing to see what would happen if i set Reddin as essential, but i'm not sure on how to find the base_ID for them. I open up console and click on her, but it says Initiate Reddin (0001D42E) (this is different from the "0001D42F" that fallout.wikia says) why is mine different, and why can't i do "setessential 0001d42e 1" yet "setessential 0001d42f 1" works..

I use the G.E.C.K. (editor) for this. The Base ID is called Form ID in the editor. In the console, when you click on something, you get the Reference ID. Check the Form ID for more info. GobTheGoul 17:52, 10 February 2009 (UTC)
The form_id page no longer gives the base ids. These are now included in the fallout 3 characters page.
I have amended the pointer in this article to point to the correct page. 86.181.66.144 16:47, May 7, 2010 (UTC)

Finding Base IDs from Reference IDs with the console

Does anyone know how to find a Base ID of an object with the console when you have the Reference ID? This way I don't have to remember any codes as long as I find one of them in the gameworld. I think there should be a command for it, but I haven't found it yet. --Anonymous 19:12, 21 May 2009 (UTC)

Getting Items

How do you add non-weapon items to your inventory, specifically Nuka Cola Quantum? when i try to add them, it says object parameters or something is mot valid. What are these and how do i remove them?

player.additem <objectid> <how many> and hit enter 
 that should do the trick
 62.194.26.118 21:01, 7 May 2009 (UTC)

Bugged number keys

There is a bug with Hungarian keyboard, it is impossible to write a zero into the console, because the normal zero key turns the console on/off and the numpad is not working, regardless the state of numlock. The only way to execute a command with zero(es)in it, is to put the command in a batch file, and then execute the batch file. Consider adding this to the article.


I think there is a way in the coding of the game to change the key that opens up the console. 
 I dont know how, but im sure if you did some digging, that it would come up somewhere. --98.228.136.229 20:11, 11 June 2009 (UTC)



Megoldás: nyomd meg kétszer a gombot. Nem felejti el a félig beírt parancsot és beír egy nullát.Amitakartok 18:12, February 23, 2010 (UTC)

Objectives

Is there a way to find the ids for quest objectives and set them as completed?--87.54.195.72 11:27, 10 May 2009 (UTC)

Script batch variables

Is there a way to use variables in scripts run from console ? like

Float MyPosZ
set MyposZ to player.getpos Z
set MyposZ to MyposZ + 50
player.setpos z to MyposZ

or only in mods ? Nothing i try works (like this example). Any other character but CR ends commands ? I tried with 'Float MyposZ \' and some others, but no luck.

Modify NPC stats?

Is there a console command that can set stats for NPCs? If so, what's the correct command?--Kajex Firedrake 07:46, 21 May 2009 (UTC)

read the article page one more time --ThorX 07:46, 25 May 2009 (UTC)

Refilling containers

How do I refill a container using the console, e.g. nuka cola machine? I mean not the additem command, I need something like "resurrect" for NPC's (which respawns NPC and its inventory), so basically I need to randomly respawn items within the container. -- Unsigned


Please sign your posts.You could always try selecting the object in the console and then entering the commands disable followed by enable that should theoretically work. The commands disable and enable used together in the right order reset scripts unless im mistaken. -- DisturbiaWolf13 23:05, January 6, 2010 (UTC)

modav and forceav commands

I just did some experiments with the 1.4 patch. It is a little inaccurate to say that the modav command will "peak naturally". The PipBoy's display will be capped at 100 and 10 for skills and stats respectively, but by using the player.getav command, you'll see that values greater than the PipBoy display cap are actually recorded by the game. However, it seems that for calculation purposes, pushing stats or skills beyond their PipBoy caps has no effect.

220.255.7.226 16:31, 16 June 2009 (UTC) weelillad

Is There a way to use console commands on the xbox 360 version?

I have FO3 for the 360 and I was wondering if you can use console commands by plugging a keyboard into the console?

Basically, No. They probably ripped out the console on that anyway, but that makes no difference seeing as you cant use the keyboard in the first place - the only bits you can use it on is the bit where you choose your name

Base ID for an allied turret

I want to put some turrets around a building but all base ID's for MARK II, MARK IV and MARK VI turrets are hostile (there is one MARK IV turret seems ally but deactivated). Is there a base ID for an ally turret (like the ones front of Citadel)?

Bugs

I installed broken steel and at the beggining,when elder lyons should speak to me,he bugs at the door. I brought him to me,but he didnt start conversation. Is there any way i could fix it? Sorry for sppeling

Is there a Command to recruit NPCs?

I killed the Paradise Salvers but wanted to recruit Clover, is there a possibility to do this via commands after i resurrected her?


you can by entering "resurrect" in the console


and if you enter "resurrect 1" the npc will stand up as if he/she were unconsis note:if the npc was gibed then this may produse some very silly results

critchance

Just added the player value critchance to the list. It read out 15 for me, assuming it's a percentage value I set it to 100. I'll update in a bit when I've tested it out to see if I actually crit 100% of the time.

Something tells me there's a value for critical damage modifier as well. However I haven't found this with random testing yet. If anyone knows what it is, please tell me (or better yet, add it to the list ;) ).

--PointSingularity

EDIT: Umm, ok... seems the page reset so edit yourselves then!

Anyways, critchance works... splendidly! Theres also "poisonresist" for well... resisting poison. As a side note the resistances can only be maxed at 85 (%) and any value higher will be used as this max in-game.

--PS


EDIT 2: Nevermind, it appeared again. I was probably looking at a cached page for some reason (I did delete my local cache just ftr).

I added the poisonresist one as well. I also added info on resist and SPECIAL caps. Oh and I just noticed the sign note so I guess I'll sign my post this time around. ;) 83.226.177.46 08:40, 19 August 2009 (UTC)

huge empty spaces

Is there a reason for the empty space added in the last edit (in the .txt files part)? --Vipermagi 18:58, September 9, 2009 (UTC)

Problems Using "additem" with Plug-in

I am having an unusual problem with items added by a plug-in for FO3 called "WW2 Uniforms." Whenever I try to use "additem" or "removeitem" with the FormIDs, as they are given in GECK, the console returns saying that the ObjectID isn't found. For example, the British Army Hat added by the mod has a FormID of 010022C2, but the game can't recognize it. Is there some difference between the FormID and ObjectID of which I'm unaware? I always thought they were the same thing.

EDIT: I found the answer after some digging. The only difference between the FormID and ObjectID, it appears to me, involves the first two numbers of the ID. It's 01 on the FormID in this example, but those first two will refer to the index number of the data file, which has to do with when it loads compared to other files. If you download FOMM it will show you the index numbers. In my case, for the mod in question it's 05. So if I type "player.additem 50022C2 1," as opposed to "10022C2," it works because it is now properly referring to the file that contains it.

71.184.47.19 12:38, October 18, 2009 (UTC)

SetPCyoung

I've tried multiple times to get the code that turns you into a child to work but I have never had any luck. Is there a special code that you have to enter before it to make it work? or am I just screwed. I've tried the gender change code and it worked so I wonder why this won't.--209.208.106.242 23:01, October 25, 2009 (UTC)


Edit the agerace property of the npc. Deducting 1 will make them younger.


i.e (click on npc) agerace -1

set npc to friendly/companigon

how can i set nps (some brotherhood outcasts perhaps) as friends so they escort me and protect me?

I might have discovered a new console command

You no how In some places you can't fast travel well I found the command "enablefasttravel 1"(or 0) I don't know if there's a command "disablefasttravel" but I know for a fact the first one works please don't confuse it with "tmm 1" as it dose not provide map markers it just lets you use them

Charon death

Hey, I just finished running through Mothership Zeta for the first time. (awesome, btw)

Unfortunately I didn't know it would have both of my followers, who were camped at My Megaton Home at the time, show up randomly outside the beacon location. This resulted in a Yao Guai nom-noming Charon. I thought, "hey, no problem, I'll just rez him" Only...he resets to the "no, go talk to Ahzrukhal" text rather than follow me....this is a problem considering he long ago blew Ahz away and I already have the contract. Anyone have any ideas on how to set Charon's behavior to a follower? Thanks.

You might try removing the contract from your inventory via console commands, ressing Azrukhal and starting over?

Karma changing?

player.forceav karma and player.modav karma don't work for me... It just says something along the lines of "Actor value "karma" cannot be modified in scripts or console" Does anyone know why this is happening, because it worked for me before... If it helps, I'm patched up to the latest version and I've got all the DLC except The Pitt. 77.105.22.115 14:45, January 6, 2010 (UTC)

Yes those codes dont work for me either, it says that karma isnt an actor value.What i seem to remember working for me is this: player. rewardkarma #

# = number of karma points you want to add.However i dont think this works for taking karma away from the character...sorry and i hope it works -- DisturbiaWolf13 23:18, January 6, 2010 (UTC)

Actually you can reduce you're karma by typing player.reweardkarma -(anyvalue) -- alwe9704

Swapping items from multiple characters

Someone please tell me: is there a command to swap every single instance of an item wielded by NPCs with another? I know there are mods to do this but what I need is a way to be able to swap any item with any item over multiple NPCs simultaneously. Say, replacing V101 jumpsuits with Enclave uniforms.Amitakartok 23:26, January 19, 2010 (UTC)

The general, unnamed characters probably have a file somewhere that gives characters their items. You HAVE to change those settings if you want unnamed characters to be affected, I think. For named characters, I think you would have to swap clothes one by one. You can do that via console, though, so I would recommend writing a batch file. - 88.159.237.128 06:45, January 20, 2010 (UTC)

In my example, I meant replacing every single jumpsuit in the game, no exceptions. If it's not possible from the console, there has to be a way to do it from GECK.Amitakartok 18:02, February 23, 2010 (UTC)

Pausing the game?

Can you pause the game through console command and still move/move the camera?Birdie94jb 12:59, January 24, 2010 (UTC)

As far as I know, no. -- Porter21 (talk) 13:03, January 24, 2010 (UTC)

If you are using the console, 'tfc 1' will toggle floating camera and pause the game.12.145.63.2 19:59, April 23, 2010 (UTC)SB

Anyway to "reset" an event via Console?

I did not get to see the battle between the AntAgonizer and the Mechanist when I entered into Cantebury Commons.

Is there any console command that I can use to reset The Battle?


I walked into Cantebury Commons unknowingly, and went into Dom & Machette's House before anything.

When I walked out of the house, Roe ran up to me and the dialog reflected as if I witnessed the battle

between the 2. Every other NPC's dialog also reflects this, But I did not get to see the battle =-/

Any help would be greatly appreciated.

Radiation

Is there a command that will increase/decrease the amount of rads that you have attained? I believe that it's a character value, so it might be something like player.modav radiation (# of rads needed) or something like that. Any idea's are helpful! Also, does setting rad resist to a negative number increase the speed that you attain rads? I'm working on the wastelands survival guide quest, and the longest part, for me at least, is the radiation part. Timmage 01:50, February 3, 2010 (UTC)

For that quest, just go to the bomb in megaton and keep drinking the water(or any irradiated water source). You'll get the required radiation in less than a minite. 86.153.41.96 15:40, March 11, 2010 (UTC)

Missing console command

Do anyone know the console command for spawning actors?



Cant find it



AND FFS ANSWER!!!!


Everybody keeps ignoring

NPC Console Command.

I have also had trouble finding the codes for NPC's such as the Brotherhood members and Enclave soldiers, if anyone could help out, it would be much appreciated.

Find a game spawned enclave and click him while in the console then you should get the code62.131.11.87 16:30, March 6, 2010 (UTC)

Here is a list of IDs

http://uk.gamespot.com/pc/rpg/fallout3/show_msgs.php?topic_id=m-1-46856167&pid=918428&page=0

Troubleshooting

Console Access

It's common for Vista users and some XP users to be unable to access the Console. Following are some possible causes & solutions: "Infrared Device" drivers interfere with the "Tilde" (~) key being able to access the Console, so must be disable/uninstalled. Here's a direct quote from Bethesda Softworks Technical Support: "If you have a new system with the Microsoft eHome devices, these will conflict with the program being able to read the scan code for the tilde key from the keyboard. Those Microsoft eHome devices or drivers need to be disabled in order to allow the game to "see" the tilde key being pressed. The MIRC (Microsoft Infrared Remote Control) seems to disable the tilde (~) key in both Oblivion and Morrowind. Simply disconnecting the MIRC from the USB port will fix this issue." To Unistall/ Disable the conflicting device(s), try the following steps: Open up the "Start" menu, go into "Control Panel" > "System and Maintenance" > "Device Manager". Click "Human Interface Devices". If you see "Microsoft eHome Infrared Transceiver", right-click and uninstall it. If not, then locate the driver with the word "Infrared" in it's name elsewhere in the Device Manager and uninstall. Unfortunately, when you turn-off and then restart your pc, it will automatically reinstall the driver. As a result, you'll have to repeat the uninstall procedure whenever you go to play and wish to have access to the Console. -or- [Temp Fix] Control Panel > System > Hardware > Device Manager > Human Interface Devices > uninstall Infrared driver (don't ask me why but this driver interferes). If using a controller, you have to switch back to mouse/keyboard control to get the console, switching to mouse/keyboard control will occasionally crash the game to desktop, so save before you try, just in case. (Tested with 360 controller on Vista 32)[Works also on Vista x64 with xbox 360 controler] It has been reported that the console will not work with some Vista 32 and 64 bit systems with NO fix. Those people can only hope for a mod that solves this (example - the ring of console in Oblivion). For Vista 32 and 64 bit http://www.fallout3nexus.com/downloads/file.php?id=1711 its a mod for the Console and works HOWEVER, try this, before giving up and using the ring of console. This editor has no infrared device drivers, and tried this. It worked. Open regedit (Go into Command Prompt and type in regedit... this will open a new window.) Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\i8042prt\Parameters There should be an entry named OverrideKeyboardSubtype with a type of REG_DWORD and a value of 2. Set the value to 0 and reboot. now, uninstalling the IR drivers in the device manager (if you have them) will work to enable the console to come up. if you don't have any IR drivers, then just doing the reg change should fix it for you.


It should also be noted that on the Windows7 platform, the console will not open due to compatibility issues. Bethesda may or may not be working on this problem in the form of a patch.

You should try this first:

Tested and working method under Vista and Windows 7: http://www.cheathappens.com/show_board2.asp?headID=74895&titleID=14053 This will work not only for Fallout 3, but all other games that use the "~" for console, AND lets you use your MS remote. This was an insta-fix for any laptop w/ a built-in detacheable remote. It also has less technical than registry entry edits, (and their eventual complications), and isn't nearly as sketchy as uninstalling and reinstalling the device/driver. A+ perma-fix for media centre comps/laptops.

Ring of Console fix

Follow the steps on the page to help activate the console. The page can be found at here. You must have the original ring of console as well. NOTE: This is only for users who CAN NOT under any circumstance open the console. Please try other solutions before resorting to this option, you might save yourself some time. This mod is in a beta, so use at your own risk. This mod works in the same way as the Ring of Console, and the item is gained after you escape from the vault.

Console Key Binder fix

An easier alternative to the Ring of Console fix would be the Console Key Binder mod, removing the hassle of equipping/unequipping an item. The file can be found here. This mod allows you to bind another key to open the console (default is F4) which is very useful if your tilde key does not work. Take note, however, that this mod requires Fallout Script Extender (FOSE). FOSE can be found here.

Microsoft eHome remote/receiver

If you use the Microsoft eHome remote/receiver (official media centre remote and USB receiver) you'll notice under your device manager you have a new device named Microsoft eHome MCIR 109 Keyboard; this is the cause of the tilde key not working. It also affects your plus, minus, parenthesis, hash, @, and slash keys remapping them to different functions. (some are even Kanji characters) NOTE: Many "ITECIR" (infrared) drivers under the device manager also cause the same issue. Solution is as follows and will not affect the functionality of your Media Centre remote: 1. Go into Device Manager -> Keyboards. 2. Right-click "Microsoft eHome MCIR 109 Keyboard", choose "Update Driver" ("Update Driver Software" on Vista). 3. Choose "Browse my computer for software" (XP users tell it not to install automatically and say you'll specify the location, then when it asks you where you would like it to search for drivers choose the option to choose from a list) then "Let me pick from a list of device drivers on my computer". 4. Make sure "show compatible hardware" is checked, then select "HID-compliant device" and click next. Click any remaining "OK" or "Finish" buttons after Windows has installed the driver.

AutoHotKey Fix

AutoHotkey is a free, open-source utility for Windows, used to remap keyboard or mouse buttons. If your "Tilde" (~) key isn't recognized in Fallout 3, one fix is to install AutoHotKey, and in the script used by the program, assign the "~" to another key. For example, to turn "F12" into a "~", use the line: F12::~ Now "F12" will be recognized as the command line button.   phoenix  txt  xp  11:33, March 17, 2010 (UTC)

Additional batch file examples

  • This batch file gives you a lot of ammunition, as well as some grenades and mines.

---ammo.txt---
player.additem 0006B53C 90000
player.additem 000207F7 90000 
player.additem 0002937E 90000 
player.additem 00004241 90000 
player.additem 00078CC4 90000 
player.additem 00004240 90000 
player.additem 0006B53D 90000 
player.additem 000615A8 90000
player.additem 00029364 90000 
player.additem 0002935B 90000  
player.additem 00047419 90000 
player.additem 0002936E 90000 
player.additem 000615AF 90000 
player.additem 0006B53E 90000 
player.additem 00020772 90000 
player.additem 00078CC2 90000 
player.additem 00029371 90000
player.additem 00078CC1 90000 
player.additem 0006A80D 90000 
player.additem 00078CC3 90000 
player.additem 00004485 90000 
player.additem 00020799 90000 
player.additem 000B8791 90000
player.additem 0005F706 90000
player.additem 00078CC5 90000 
player.additem 00029383 90000
player.additem 00029384 90000
player.additem 00028EEA 90000
player.additem 0004C5F9 90000
player.additem 00056634 90000
player.additem 00004342 20 
player.additem 0000433A 20 
player.additem 00004330 20
player.additem 0000433C 20
player.additem 0000433D 20
player.additem 00004331 20
player.additem 0000433E 20

  • To find all the positions of a selected object (x position, y position, z position; x angle, y angle, z angle) all at once you can use the bat command with a text file containing the getpos and getangle commands. To execute the command, you would type bat pos

---Pos.txt---
GetPos X
GetPos y 
GetPos z
GetAngle x
GetAngle y
GetAngle z

  • This batch shows the most relevant information about NPCs and enemies. Select a NPC or enemy and type bat info

---Info.txt---
getav Health
getav DamageResist
getav SmallGuns 
getav EnergyWeapons
getav BigGuns 
getav Explosives 
getav MeleeWeapons
getav Unarmed

iConsoleText in Fallout.ini

The position of console text can be set in the Fallout.ini file. In Windows XP at:

C:\Documents and Settings\<username>\My Documents\My Games\Fallout3\FALLOUT.INI

For Vista and Windows 7:

C:\Users\<username>\Documents\My Games\Fallout3\Fallout.ini

Open the file in a text editor like Notepad. Search for "iConsoleText".

  • Set iConsoleTextXPos to 200 or so. Higher figures move console text to the right. This is the main problem.
  • IConsoleTextYPos should be approx. 100 or 200 less than your Y resolution. Lower figure moves it up (0 is the top of the screen).

An example for a 1280x1024 (XxY) 5:4 display:

Setting            Default  New Setting  Notes
iConsoleTextYPos     940        900      Y (up/down) pos is 100-200 less than your Y res (here, 1024)
iConsoleTextXPos      30        200      X (left/right) position is higher (which moves it to the right)

Videos

The videos are unavailable for me, it says "contains copyrighted material of Sony Music and has therefore been deleted for your country" (which is Germany in my case). Could someone check if that's the case for other countries? If the videos have been made unavailable for most people worldwide (I'm uncertain about Youtube's deletion policies, which are debatable anyhow, but that's another issue), then the links could IMO be removed from the page. I just wished people would refrain from using some supposedly cool tunes that will cause only problems and are not helpful in any way but rather quite distracting in an educational video like this.--87.156.247.124 11:03, March 26, 2010 (UTC)

Direct console input possible ?

Hey dere folks !!!


Does anybody know if its possible to submit consolecommands without opening the console ?

F.e. to submit "bat" commands via a macroprog.

Is there any "bypass console 'cvar" I didnt find so far ?


Thx in advance

93.83.225.138 01:49, May 25, 2010 (UTC)Old Dirtbag93.83.225.138 01:49, May 25, 2010 (UTC)

unsettingownership

Hi just wanted to know how to unset ownership once you have used setownership.

can`t figure it out

wastlander

115.133.123.248 01:33, June 1, 2010 (UTC)

Community content is available under CC-BY-SA unless otherwise noted.

Fandom may earn an affiliate commission on sales made from links on this page.

Stream the best stories.

Fandom may earn an affiliate commission on sales made from links on this page.

Get Disney+