This talk page is only for discussing improvements to the page "Gamebryo console commands."


NPC Manipulation

I've made the "NPC manipulation" more readable and user-friendly, and also added some console command info (multiple follower and cloning yourself) that someone had wrongly written in Exploits (that I will remove from that article shortly).

The spaces between some lines are there for readability and semi-categorization, but I can imagine someone would object to the aesthetics of it (I, for one, like it).

EDITING NEEDED: The resetting your companion example in the end needs explaining - why/when is it useful, what is its purpose?

ALSO, HOW DOES THE RESET QUEST WORK? I cloned Clover and after making her hostile my other followers (including the real Clover) killed her, and I received the "Clover is dead" message. Clover now gives the "take it up with Euology" reply when I try to talk to her, even if she follows me around like normal.

So I tried the resetting the "hire quests" as instructed, in all possible variations: resetting the quest with both resetquest 0x000943ec and resetquest 000943ec, using prid and not using prid. I got no error message, but nothing changed and I still get the same generic response when trying to talk to her. To check if the code was wrong I tried resetquest 0x000371d2 with Charon and same situation, but he too kept giving generic responses. What am I missing here?

Thormodr 18:56, June 10, 2010 (UTC)

Are you actually typing in "0x000943ec"? that seems strange, because X isn't a digit in the hexadecimal system. For hex values like these, you should just forget about the initial zeros. They don't matter. You only need to use the full value when there is another number there in the beginning, i.e., you've modded the game and are trying to play around with a non-vanilla (that is, not part of the original game) item or quest. Since there are very few quests that aren't vanilla, I think it's important for people to remember that when dealing with the console and the original game itself, you've got to think a little like a developer. They don't really want to type a thousand zeros when they know the zeros don't make a difference. Try just ignoring the first numbers if you're messing with things in the original game (vanilla game). For example, try simply entering "943ec" rather than using "00000943ec". See if that helps you (or anyone else frustrated with the console). You only need to use the full string if you've added a mod file, and in that case I'd recommend Fallout Mod Manager (FOMM) so that you'll know what number needs to be placed at the beginning of the string (i.e., 010000..., 020000...., 0a0000..., 0f0000..., etc). Marxismoney 07:29, January 3, 2011 (UTC)

Major cleanup

I did a rather thorough testing of commands and cleanup of the page. It's probably more useful now.


Commands left to evaluate:

  • addspecialpoints # - Add # special points
  • DisableAllMines - Disables mines
  • EnablePlayerControls - Move around during "locked" cinematics
  • getXPfornextlevel - Displays xp needed for next level
  • modpca (SPECIAL) # - Adds X points to your SPECIAL stat.
  • setgs fJumpHeightMin # - (1000000 approximate max), Changes how high your player will jump. Replace the # with the desired height. (default = 64)
  • setgs fMoveRunMult #- (doesn't work on fallout 4) - Changes run speed. Replace the # with the desired speed. (default = 4)
  • setgs iMaxCharacterLevel ### - Sets the maximum level that your character can reach through experience gain. Replace the ### with the desired maximum level.
  • SetPCCanUsePowerArmor 1 - Allows player to wear any piece of power armor without the training prerequisite.
  • tcai - Toggles combat AI on/off. Enemies stand still and do not fire back. Some will still continue their patrol-route.
  • tg - Toggles grass on/off.
  • tt - Toggles trees culled/not culled.

/Mirar 10:47, 11 December 2008 (UTC)


I got this from , sorted it alphabetically and changed a few things. I didnt test all the commands. Conradesc 10:45, 13 November 2008 (UTC)

How do you set ownership of beds and stuff? I'm evil and I want to kill Silver and claim her house as my own.

console, click on item, 'setownership'. --ThorX 06:10, 10 May 2009 (UTC)

Thanks for quick ownership addition... "SetEssential" 1 and "setessential 6a772 1" both do not work for me, however I've had alot of console issues...

"SetEssential <base id> 1" you have to type the whole base id in so i think yours would be 0006a772.

tagged skills

is there any way to edit tagged skills in the console? is there a command that can let you tag all skills, or to let have 13 tag skill allocation points at character creation? 17:40, 28 November 2008 (UTC)

AddPerk & RemovePerk

These two need more elaboration on how to use them. Were I trying to add Toughness, even after targetting myself in 3rd person, nothing happens when I type...

  • AddPerk
  • AddPerk Toughness
  • AddPerkToughness
  • AddToughness

Servius 04:19, 8 December 2008 (UTC)

Don't type "Toughness." You need to enter in the code for the perks, which can be found here. 05:49, 8 December 2008 (UTC)
Thanks, I updated the main page. Servius 13:35, 8 December 2008 (UTC)w
Updade: you can add perks by entering Console|"Addperk <perk baseID> <ref ID (optional)>


In oblivion, excessive use of the placeatme command can lead to instability... I'm not sure if this is the same in fallout 3, but I would still warn people about it. 12:18, 14 December 2008 (UTC)

  • Using the command "MarkForDelete" on a PlaceAtMe'd ref will destroy the ref once it's been disabled. --MadCat221 01:06, 27 January 2009 (UTC)
I noticed this command does not work for npc's that are placed on the map via random encounters. - Redmess 22:19, November 29, 2009 (UTC)

Add items with condition

Uh, actually the "player.additem base_id amount quality" is wrong. The "additem" command won't take the third "quality" parameter and always gives weapons/armors with 100% condition, thus the third "100" in lots of item pages is useless. The correct command should be "player.additemhealthpercent base_id amount quality." EX: "player.additemhealthpercent 80B 3 0.97" gives the player three Chinese Assault Rifles with 97% condition. Reference: hey is there a way to use player.additem on DLC obkects? i tried with several armors and weapons from broken steel but must have been doin something wrong i typed 'player.additem 1081 1' for hellfire armor but didnt work any suggestions?

Yes, you have to put a two-digit number where the xx is in the base id on the hellfire armor wiki page. Click the xx for an explanation. --HunterZ 15:49, April 24, 2011 (UTC)-- 01:44, February 16, 2012 (UTC)

toggledebugtext... bugged?

toggledebugtext is suppose to give you information like framerate, ect, but it's not showing anywhere on the screen when I activate the command. -- 15:27, 31 December 2008 (UTC)

Cloning Player

I remember in Oblivion that you could clone yourself. He/She wouldn't do anything but you could kill him/her to loot all the stuff that you have in your inventor. Could it possibly be the same as Oblivions cheat "code" for it since many other commands are similar or the same. But what i want to know is, is there a command to clone yourself? -- 23:32, 1 January 2009 (UTC)

Well I know you can use player.placeleveledactoratme followed by the form id '7' to create a clone of the player, but that clone, from my little test attempt, has no items. -- 01:39, December 21, 2009 (UTC)

player.modav "energy weapons"?

what is the command to modify your energy weapon value? Kenji 03 19:14, 5 January 2009 (UTC)

Well, if you want to modify it by five, it'd be "player.modav energyweapons 5" that would change an Energy Weapons skill of 15, to a level of 20. A better way to do it is to select a number, say, 75 and type "player.forceav energyweapons 75" which gives the actual number input as the final result.Fiddlesoup 06:09, 10 January 2009 (UTC)

Using forceAV can be risky. (the game will not be able to add or subtract from this value after a forceAV. for example player.forceAV carryweight 500 caused my overencumbered to always be 500 even after leveling) using setAV allows the game change it later.

using setAV also works -- 18:49, December 27, 2010 (UTC)

Incorrect AddItem code syntax

The "AddItem" code information used throughout the site is incorrect. The current syntax, "AddItem <objectID> <quantity> <health>" isn't accurate. The value listed at the "health" spot is actually a flag for making the notification message at the top-left of the screen not show when it gets added (used in scripts to cut down on message spam), and then only if the flag's value is 1 (thus the 100 value does nothing). AddItem will automatically add the weapon to the calling object at 100% health regardless.

If you're wanting to add an item with a health less than 100, then you need to use the console command "<callingref>.AddItemHealthPercent <objectID> <quantity> <health> <messagehiddenflag>". --MadCat221 01:04, 27 January 2009 (UTC)

Well, since no one else had done anything, I've changed it.Fiddlesoup 22:05, 4 February 2009 (UTC)

No hostility?

I need to make a NPC non hostile, and be able to talk to this NPC. Reason being, I killed an NPC, and I need to talk to him, but he attacks me if I use "resurrect". What do I do?

This mod worked perfectly for me after failing at using console commands like "setav agression 0", "player.SCAOnActor", and "stopcombat". --RizzleQ 15:51, 10 August 2009 (UTC)

setav aggression 0 works just fine, you probably typod aggression :)

Related Note: I have a similiar issue, I killed everyone but Motor-Runner in Vault 3. I entered his room and he said piss off so I did, because I figured he'd be tied to a quest. Turns out he is, for Diana but if I return to him he (and his dogs) are hostile (red) on the UI but I can still talk with the only option being to say "I was just leaving". Is there a way to reset him to green (yellow on the default UI for New Vegas) so I can talk to him for the quest?

Is there an alternative way to fix this? please email me - tehsorrow

Gameplay issues

After fooling around in console, my game is running extremely slowly. As a joke, I made a few hundred burkes and blew them up, then fought a giant Zip. I didn't save, but ever sense then Fallout 3 has been running incredibly slow on my computer, especially in VATs. Any ideas as to what's going on? --Nux Matrix 02:19, 8 February 2009 (UTC) this slowness you mentioned has happened to me too, though I did NOT use the console. I think it might be some graphics glitch..or not. Is anyone with the graphics set to Low Quality having the same problem? My laptop is an HP,vista,64-bit.I have been experiencing things from horrible lag, game freezes, my laptop saying that "Fallout has stopped working", to the dreaded case of my laptop in a state between shutting down and being on for 20 minutes before I was forced to temporarily remove the battery.Any help would be gratefully accepted. --A Gamer on his Last Legs (metaphorically)

This happens to me too, unrelated to things i do (i guess), PC reboot does the trick, some super sledge might too :). It might be related to too many scripts running in the cell, donno.

Weapon & Ammo Codes

.32 Pistol 00050F92
10mm Pistol 0001A334
10mm SMG (Sydneys "Ultra") 0006E7CC
10mm Sub Machine gun 00004321
A3-21's Plasma Rifle 0006B539
Acid Spit 000B8793
Alien Blaster 00004322
Ant's Sting 000C553E
Assault Rifle 0001FFEC
Baseball Bat 0000421C
BB Gun 000C0327
Black Bart's Bane 0006B535
Blackhawk 000303A2
Board of Education 000C310F
Bottlecap Mine 0000433A
Brass Knuckles 00004324
Breaker 000CB546
Butch's Toothpick 00078440
Buzzsaw 0003BC6F
Chinese Assault Rifle 00046BDD
Chinese Officer's Sword 0002B3CB
Chinese Pistol 00004325
Chinese Pistol (Zhu-Rong v418) 00060C2C
Clover's Cleaver 000C80B8
Col. Autumn's 10mm Pistol 0006B531
Col. Autumn's Laser Pistol 000ABBE4
Combat Knife 00004326
Combat Shotgun 00004327
Curse Breaker 000C80BB
Dart Gun 0000432A
Deathclaw Gauntlet 0000432B
Electrical Zap 00022FF1
Eugene 0006B538
Excalibat 000C80BC
Experimental MIRV 0003422B
Fat Man 0000432C
Fawkes' Super Sledge 0007843F
Fire Hydrant 00021367
Firelance 000C80BA
Fisto! 000CB601
Flamer 00078C6
Frag Grenade 00004330
Frag Mine 0000433C
GasTrap Dummy 000001F6
Gatling Laser 0000432E
Hand Laser 00018B9E
Highwayman's Friend 00078442
Hunting Rifle 00004333
Jack 000C6E5B
Knife 00004334
Laser 00050ED0
Laser Pistol 000B4178
Law Dog 0006B532
Lead Pipe 00004337
Liberty Laser 00033FE2
LibertyPrimeWeapBomb 0005932F
Lincoln's Repeater 0003C07A
Love Tap 000C80B9
Mesmeron 00004339
Mesmetron 000BF5A4
Minigun 0000433F
Mirelurk Bait Grenade 00030664
Miss Launcher 000B2644
Missile Launcher 00057E8F
Nail Board 000A01DD
Nuka-Grenade 00004342
O'Grady's Peacemaker 0007843D
Occam's Razor 000CB602
Ol' Painless 00066C76
Plasma Grenade 00004332
Plasma Gun 0007C10C
Plasma Mine 0000433D
Plasma Pistol 00004343
Plasma Rifle 00004344
Plunkett's Valid Points 000CAFA9
Police Batton 00004345
Pool Cue 00004346
Power Fist 00004347
Protectron's Gaze 000C553F
Pulse Grenade 00004331
Pulse Mine 0000433E
Radioactive Spit 00058717
Railway Rifle 00004348
Repellent Stick 0002D3B7
Reservist's Rifle 00092966
Ripper 00004349
Rock-it launcher 0000434B
Rolling Pin 00029769
Rolling Pin 000B2943
Sawed-Off Shotgun 0000434C
Scoped .44 Magnum 0000434D
SentryBot Laser Gatling 000389AF
SentryBot Minigun 00057E8E
Shishkebab 0000434E
Shriek 0007F598
Silenced 10mm Pistol 00004350
Slasher Knife 0002869C
Sledge Hammer 00004351
Sledgehammer 00063FA2
Smuglers End (Laser Pistol) 0006B536
Sniper Rifle 00004353
Spiked Knuckels 00004354
Stabhappy 000C80BE
Super Sledge 000B0E7C
Sydney's 10mm "Ultra" SMG 0005DEEE
The Break 00066C77
The Kneecapper 0006B53A
The Shocker 000BFF62
The Tenderizer 000A874B
The Terrible Shotgun 0006B534
Tire Iron 00004328
Vampire's Edge 00078441
Vertibird Bomb Gun 0003E5E2
Vertibird Gun 00089C51
Victory Rifle 000CB548
.308 Caliber Round 0006B53C
.32 Caliber Round 000207F7
.44 Round Magnum 0002937E
10mm Round 00004241
5.56mm Round 00078CC4
5.56mm Round 00004240
5mm Round 0006B53D
5mm Round 000615A8
Alien Powercell 00029364
BB - Ammo 0002935B
Bottlecap Mines 0000433A
Dart 00047419
Dart 0002936E
Electron Charge Pack 000615AF
Electron Charge Pack 0006B53E
Energy Cell 00020772
Energy Cell 00078CC2
Flamer Fuel 00029371
Flamer Fuel 00078CC1
Frag Grenades 00004330
Frag Mines 0000433C
Mesmetron Power Cell 0006A80D
Microfusion Cell 00078CC3
Microfusion Cell 00004485
Mini Nuke 00020799
Missile 000B8791
Missile 0005F706
Missile 00078CC5
Missles 00029383
Pulse Grenades 00004331
Railway Spikes 00029384
Shotgun Shell 00028EEA
Shotgun Shell 0004C5F9
Sonic Energy 00056634

Finding IDs

I just felt like testing to see what would happen if i set Reddin as essential, but i'm not sure on how to find the base_ID for them. I open up console and click on her, but it says Initiate Reddin (0001D42E) (this is different from the "0001D42F" that fallout.wikia says) why is mine different, and why can't i do "setessential 0001d42e 1" yet "setessential 0001d42f 1" works..

I use the G.E.C.K. (editor) for this. The Base ID is called Form ID in the editor. In the console, when you click on something, you get the Reference ID. Check the Form ID for more info. GobTheGoul 17:52, 10 February 2009 (UTC)
The form_id page no longer gives the base ids. These are now included in the fallout 3 characters page.
I have amended the pointer in this article to point to the correct page. 16:47, May 7, 2010 (UTC)

Finding Base IDs from Reference IDs with the console

Does anyone know how to find a Base ID of an object with the console when you have the Reference ID? This way I don't have to remember any codes as long as I find one of them in the gameworld. I think there should be a command for it, but I haven't found it yet. --Anonymous 19:12, 21 May 2009 (UTC)

With FOSE you could use GBO (GetBaseObject) but I'm not sure if that function made it into NVSE 1.0 Beta or not. --Kris User Hola.jpg 01:52, November 9, 2010 (UTC)

Getting Items

How do you add non-weapon items to your inventory, specifically Nuka Cola Quantum? when i try to add them, it says object parameters or something is mot valid. What are these and how do i remove them?

player.additem <objectid> <how many> and hit enter 
 that should do the trick 21:01, 7 May 2009 (UTC)

Bugged number keys

There is a bug with Hungarian keyboard, it is impossible to write a zero into the console, because the normal zero key turns the console on/off and the numpad is not working, regardless the state of numlock. The only way to execute a command with zero(es)in it, is to put the command in a batch file, and then execute the batch file. Consider adding this to the article.

I think there is a way in the coding of the game to change the key that opens up the console. I dont know how, but im sure if you did some digging, that it would come up somewhere. -- 20:11, 11 June 2009 (UTC)

Megoldás: nyomd meg kétszer a gombot. Nem felejti el a félig beírt parancsot és beír egy nullát.Amitakartok 18:12, February 23, 2010 (UTC)

De igen elfelejti nem úgy mint a Valve játékokban 7s1ll4gk4pU (talk) 10:47, January 4, 2014 (UTC)


Is there a way to find the ids for quest objectives and set them as completed?-- 11:27, 10 May 2009 (UTC)

there is, it's not easy though. i'd suggest digging through the console as well as grabbing a copy of the New Vegas G.E.C.K., that will help you better understand the issue you're trying to solve. wish i had more info. Marxismoney 06:57, January 3, 2011 (UTC)

Script batch variables

Is there a way to use variables in scripts run from console ? like

Float MyPosZ
set MyposZ to player.getpos Z
set MyposZ to MyposZ + 50
player.setpos z to MyposZ

or only in mods ? Nothing i try works (like this example). Any other character but CR ends commands ? I tried with 'Float MyposZ \' and some others, but no luck.

Modify NPC stats?

Is there a console command that can set stats for NPCs? If so, what's the correct command?--Kajex Firedrake 07:46, 21 May 2009 (UTC)

read the article page one more time --ThorX 07:46, 25 May 2009 (UTC)

That article tells you how to set the Player's stats, what about NPCs? Like Followers or merchants ect.

Refilling containers

How do I refill a container using the console, e.g. nuka cola machine? I mean not the additem command, I need something like "resurrect" for NPC's (which respawns NPC and its inventory), so basically I need to randomly respawn items within the container. -- Unsigned

Please sign your posts.You could always try selecting the object in the console and then entering the commands disable followed by enable that should theoretically work. The commands disable and enable used together in the right order reset scripts unless im mistaken. -- DisturbiaWolf13 23:05, January 6, 2010 (UTC)

Best way I know to do it is left-click the object in the console (unless you know the object ID and then you can just "prid objectid" where objectid is its ID) and then "resetinventory" (randomly regenerates the inventory, and often comes up empty so you might have to repeat these two steps several times). --Byroniac

modav and forceav commands

I just did some experiments with the 1.4 patch. It is a little inaccurate to say that the modav command will "peak naturally". The PipBoy's display will be capped at 100 and 10 for skills and stats respectively, but by using the player.getav command, you'll see that values greater than the PipBoy display cap are actually recorded by the game. However, it seems that for calculation purposes, pushing stats or skills beyond their PipBoy caps has no effect. 16:31, 16 June 2009 (UTC) weelillad

yeah, this kind of pushing stats past 100 has been hardcoded as not-available since the early days of gamebryo (oblivion was my first gamebryo game). it makes sense, really - they didn't want people to be able to become some monsterized NPC crushing character because that would cause a lot of bugs to appear. I'd say the point is there's really no practical way to go past 100 for skills, but if you find one, do tell! (lol) Marxismoney 07:01, January 3, 2011 (UTC)

Base ID for an allied turret

I want to put some turrets around a building but all base ID's for MARK II, MARK IV and MARK VI turrets are hostile (there is one MARK IV turret seems ally but deactivated). Is there a base ID for an ally turret (like the ones front of Citadel)?


Try going to the robco facility near tenpenny tower after setting the the turrets on pest control(Wasteland survival guide mission). im not sure if they would shoot raiders and slavers though


Try the Mark VI (broken steel) turrets since those ones only need the emitter (like the ones you find in that small unmarked RHEO camp). Don't quote me but I think you need the specific turrets since only those 4 are supposed to work with the emitter. It's either that or copying a terminal and hacking your own turrets.

-Anonymouse (John)

On my way to Tenpenny tower, I discovered a member of the Brotherhood of steel and there was a ally turret. Also the event is somewhere near a fort. I hope this mysterious info helps.


I installed broken steel and at the beggining,when elder lyons should speak to me,he bugs at the door. I brought him to me,but he didnt start conversation. Is there any way i could fix it? Sorry for sppeling

check the quest ID codes? that means a lot of digging on your part. probably a simpler solution out there, like just reload the game from a previous save. Marxismoney 07:03, January 3, 2011 (UTC)

Is there a Command to recruit NPCs?

I killed the Paradise Salvers but wanted to recruit Clover, is there a possibility to do this via commands after i resurrected her?

you can by entering "resurrect" in the console

and if you enter "resurrect 1" the npc will stand up as if he/she were unconsis note:if the npc was gibed then this may produse some very silly results

add them to your Player Character Faction is one way, just remember to take them out of it again before you save your game or you might mess stuff up. Marxismoney 07:31, January 3, 2011 (UTC)


Just added the player value critchance to the list. It read out 15 for me, assuming it's a percentage value I set it to 100. I'll update in a bit when I've tested it out to see if I actually crit 100% of the time.

Something tells me there's a value for critical damage modifier as well. However I haven't found this with random testing yet. If anyone knows what it is, please tell me (or better yet, add it to the list ;) ).


EDIT: Umm, ok... seems the page reset so edit yourselves then!

Anyways, critchance works... splendidly! Theres also "poisonresist" for well... resisting poison. As a side note the resistances can only be maxed at 85 (%) and any value higher will be used as this max in-game.


EDIT 2: Nevermind, it appeared again. I was probably looking at a cached page for some reason (I did delete my local cache just ftr).

I added the poisonresist one as well. I also added info on resist and SPECIAL caps. Oh and I just noticed the sign note so I guess I'll sign my post this time around. ;) 08:40, 19 August 2009 (UTC)

seriously here, be careful when modifying calculated percentages and multipliers. if you mess around with them too much you'll find bugs appear like anything that's supposed to modify critical chance will no longer work. just a heads up. Marxismoney 07:05, January 3, 2011 (UTC)

huge empty spaces

Is there a reason for the empty space added in the last edit (in the .txt files part)? --Vipermagi 18:58, September 9, 2009 (UTC)

Problems Using "additem" with Plug-in

I am having an unusual problem with items added by a plug-in for FO3 called "WW2 Uniforms." Whenever I try to use "additem" or "removeitem" with the FormIDs, as they are given in GECK, the console returns saying that the ObjectID isn't found. For example, the British Army Hat added by the mod has a FormID of 010022C2, but the game can't recognize it. Is there some difference between the FormID and ObjectID of which I'm unaware? I always thought they were the same thing.

EDIT: I found the answer after some digging. The only difference between the FormID and ObjectID, it appears to me, involves the first two numbers of the ID. It's 01 on the FormID in this example, but those first two will refer to the index number of the data file, which has to do with when it loads compared to other files. If you download FOMM it will show you the index numbers. In my case, for the mod in question it's 05. So if I type "player.additem 50022C2 1," as opposed to "10022C2," it works because it is now properly referring to the file that contains it. 12:38, October 18, 2009 (UTC)

yeah, you've got to work with the item IDs a little bit. kinda like oblivion, they have the items "base form" which then gets turned into a "form ID/ref ID" once it actually appears in the world. probably to make inventory management easier, and basically, just because it says it's one way in the G.E.C.K. doesn't mean it will be the same code in the actual game console. 06:54, January 3, 2011 (UTC)

 ya i need help to my index says 0b and i want to copy the tommy gun mod so i can give it to my companions but im haveing truble please help


I've tried multiple times to get the code that turns you into a child to work but I have never had any luck. Is there a special code that you have to enter before it to make it work? or am I just screwed. I've tried the gender change code and it worked so I wonder why this won't.-- 23:01, October 25, 2009 (UTC)

Edit the agerace property of the npc. Deducting 1 will make them younger.

i.e (click on npc) agerace -1

set npc to friendly/companigon

how can i set nps (some brotherhood outcasts perhaps) as friends so they escort me and protect me? someone else here how do you setally on FO3 i dont understand base id1 and id2

do I put the original faction then the other one I want or what?

see NPC Manipulation category on this page: Fallout:_New_Vegas_console_commands. can't guarantee it will not cause bugs in the game... this is also why someone probably suggested the two pages be merged - there must be a way to separate the new vegas commands from the older commands while keeping everything on the same page, right? Marxismoney 07:09, January 3, 2011 (UTC)

I might have discovered a new console command

You no how In some places you can't fast travel well I found the command "enablefasttravel 1"(or 0) I don't know if there's a command "disablefasttravel" but I know for a fact the first one works please don't confuse it with "tmm 1" as it dose not provide map markers it just lets you use them

there are dozens of unlisted console commands available. we simply haven't caught up with all of them, and instead made a list that you can look through yourself: Gamebryo_console_commands_(all) NOTE: Many of these commands were probably leftovers from previous games. Be careful using ones that seem like they would have no application in New Vegas.Marxismoney 07:12, January 3, 2011 (UTC)

Charon death

Hey, I just finished running through Mothership Zeta for the first time. (awesome, btw)

Unfortunately I didn't know it would have both of my followers, who were camped at My Megaton Home at the time, show up randomly outside the beacon location. This resulted in a Yao Guai nom-noming Charon. I thought, "hey, no problem, I'll just rez him" Only...he resets to the "no, go talk to Ahzrukhal" text rather than follow me....this is a problem considering he long ago blew Ahz away and I already have the contract. Anyone have any ideas on how to set Charon's behavior to a follower? Thanks.

You might try removing the contract from your inventory via console commands, ressing Azrukhal and starting over?

Karma changing?

player.forceav karma and player.modav karma don't work for me... It just says something along the lines of "Actor value "karma" cannot be modified in scripts or console" Does anyone know why this is happening, because it worked for me before... If it helps, I'm patched up to the latest version and I've got all the DLC except The Pitt. 14:45, January 6, 2010 (UTC)

Yes those codes dont work for me either, it says that karma isnt an actor value.What i seem to remember working for me is this: player. rewardkarma #

# = number of karma points you want to add.However i dont think this works for taking karma away from the character...sorry and i hope it works -- DisturbiaWolf13 23:18, January 6, 2010 (UTC)

Actually you can reduce you're karma by typing player.reweardkarma -(anyvalue) -- User:alwe9704

The same thing goes for xp, I found out -- UA

karma cannot be changed via the console, it even says so: (Reward karma does not work after you've added the FEV to the purifier. It will fail to raise you from very bad. (Even adding the very good perk via addperk does not work.) 08:45, May 18, 2012 (UTC)
Karma can be changed via the console. You just need to use the rewardkarma command rather than trying to mod, force, or set it like another actor variable. That said, the section of the main page that reads:
player.getav <variable> - read out a character value, for instance karma, intelligence or smallguns.
player.setav <variable> - set a character value to a specific amount, for instance karma, intelligence or smallguns.
Should probably not use karma as an example. Unless there's another game this article pertains to where that does work. --Trogdor
I agree that karma should not be used as an example for setav. I learned the proper way to set karma the hard way after finding out the example listed here didn't work. I'm going to go ahead and change the example to "health" instead. player.getav <variable> does work for karma, though. Darkness Squall (talk) 01:09, June 9, 2013 (UTC)

Swapping items from multiple characters

Someone please tell me: is there a command to swap every single instance of an item wielded by NPCs with another? I know there are mods to do this but what I need is a way to be able to swap any item with any item over multiple NPCs simultaneously. Say, replacing V101 jumpsuits with Enclave uniforms.Amitakartok 23:26, January 19, 2010 (UTC)

The general, unnamed characters probably have a file somewhere that gives characters their items. You HAVE to change those settings if you want unnamed characters to be affected, I think. For named characters, I think you would have to swap clothes one by one. You can do that via console, though, so I would recommend writing a batch file. - 06:45, January 20, 2010 (UTC)

In my example, I meant replacing every single jumpsuit in the game, no exceptions. If it's not possible from the console, there has to be a way to do it from GECK.Amitakartok 18:02, February 23, 2010 (UTC)

Pausing the game?

Can you pause the game through console command and still move/move the camera?Birdie94jb 12:59, January 24, 2010 (UTC)

As far as I know, no. -- Porter21 (talk) 13:03, January 24, 2010 (UTC)

If you are using the console, 'tfc 1' will toggle floating camera and pause the game. 19:59, April 23, 2010 (UTC)SB

A command that pauses everything but the players camera would be very useful for capturing those otherwise hard to catch moments. (In conjunction with tfc.) If someone happens to come across a mod that can do this, please tell. Tgp1994 01:56, July 22, 2010 (UTC)

Anyway to "reset" an event via Console?

I did not get to see the battle between the AntAgonizer and the Mechanist when I entered into Cantebury Commons.

Is there any console command that I can use to reset The Battle?

I walked into Cantebury Commons unknowingly, and went into Dom & Machette's House before anything.

When I walked out of the house, Roe ran up to me and the dialog reflected as if I witnessed the battle

between the 2. Every other NPC's dialog also reflects this, But I did not get to see the battle =-/

Any help would be greatly appreciated.

In my search for a related question, I found a site that explains how to reset a quest to any stage, even the beginning. This site has a lot of console commands and explanations listed: Start looking at line 222. for quest commands to use in the console. Especially pay attention to these lines:

  • sqs <base id> - list all quest objective levels (stages). Use with setstage.
  • getstage <base id> - gets the objective level of a quest.
  • setstage <base id> <Quest Objective> - sets a quest to an objective level useful for resetting bugged scripts

Quest IDs can be found on various sites. The site I just listed has many at the bottom of the page. Many can be found at: Console commands can also be found as listed in an answer above: and also:


Is there a command that will increase/decrease the amount of rads that you have attained? I believe that it's a character value, so it might be something like player.modav radiation (# of rads needed) or something like that. Any idea's are helpful! Also, does setting rad resist to a negative number increase the speed that you attain rads? I'm working on the wastelands survival guide quest, and the longest part, for me at least, is the radiation part. Timmage 01:50, February 3, 2010 (UTC)

There is a console command - use player.modav radiationrads x to alter your radiation level by x. 14:41, June 27, 2010 (UTC)

For that quest, just go to the bomb in megaton and keep drinking the water(or any irradiated water source). You'll get the required radiation in less than a minite. 15:40, March 11, 2010 (UTC)

"player.setav radiationrads x" messes up the radiationrads variable(my rads are 0 after setting them back to 0 but if i take any radiation i die[min and max is set to that value i guess]), use player.damageav 100 to add 100 rads or player.damageav -100 to remove 100 rads, because rads work similarly to health and (correct me if im wrong) modav/setav changes the max/total value, not the"sub"/current value. i know for a fact that setav will mess it up, but im calling it a hunch about modav, as they work with values similarly. -- 00:15, January 22, 2016 (UTC)

---quick edit--- i fixed it (steps) -- 1) "player.forceav radiationrads 0" -- 2) "player.damageav radiationrads 999" -- 3) then i healed rads at a doctor -- 00:39, January 22, 2016 (UTC)

Missing console command

Do anyone know the console command for spawning actors?

Everybody keeps ignoring

That's because the actors like staying in the real world. - RASICTalk 02:59, August 9, 2010 (UTC)
To move an existing actor to you, you need their Reference ID, which is listed on the page for that actor. Type prid followed by that refID, then hit enter and type moveto player. To spawn a new copy of the actor, you need their Base ID, also listed on page for that actor. You would then use player.placeatme followed by the BaseID, to spawn that actor at your location. You can also click on another actor or an object in the console and use the command placeatme to place the specified baseID at that location. Kris mailbox 03:16, August 9, 2010 (UTC)

NPC Console Command.

I have also had trouble finding the codes for NPC's such as the Brotherhood members and Enclave soldiers, if anyone could help out, it would be much appreciated.

Find a game spawned enclave and click him while in the console then you should get the code62.131.11.87 16:30, March 6, 2010 (UTC)

Here is a list of IDs


Console Access

It's common for Vista users and some XP users to be unable to access the Console. Following are some possible causes & solutions: "Infrared Device" drivers interfere with the "Tilde" (~) key being able to access the Console, so must be disable/uninstalled. Here's a direct quote from Bethesda Softworks Technical Support: "If you have a new system with the Microsoft eHome devices, these will conflict with the program being able to read the scan code for the tilde key from the keyboard. Those Microsoft eHome devices or drivers need to be disabled in order to allow the game to "see" the tilde key being pressed. The MIRC (Microsoft Infrared Remote Control) seems to disable the tilde (~) key in both Oblivion and Morrowind. Simply disconnecting the MIRC from the USB port will fix this issue." To Unistall/ Disable the conflicting device(s), try the following steps: Open up the "Start" menu, go into "Control Panel" > "System and Maintenance" > "Device Manager". Click "Human Interface Devices". If you see "Microsoft eHome Infrared Transceiver", right-click and uninstall it. If not, then locate the driver with the word "Infrared" in it's name elsewhere in the Device Manager and uninstall. Unfortunately, when you turn-off and then restart your pc, it will automatically reinstall the driver. As a result, you'll have to repeat the uninstall procedure whenever you go to play and wish to have access to the Console. -or- [Temp Fix] Control Panel > System > Hardware > Device Manager > Human Interface Devices > uninstall Infrared driver (don't ask me why but this driver interferes). If using a controller, you have to switch back to mouse/keyboard control to get the console, switching to mouse/keyboard control will occasionally crash the game to desktop, so save before you try, just in case. (Tested with 360 controller on Vista 32)[Works also on Vista x64 with xbox 360 controler] It has been reported that the console will not work with some Vista 32 and 64 bit systems with NO fix. Those people can only hope for a mod that solves this (example - the ring of console in Oblivion). For Vista 32 and 64 bit its a mod for the Console and works HOWEVER, try this, before giving up and using the ring of console. This editor has no infrared device drivers, and tried this. It worked. Open regedit (Go into Command Prompt and type in regedit... this will open a new window.) Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\i8042prt\Parameters There should be an entry named OverrideKeyboardSubtype with a type of REG_DWORD and a value of 2. Set the value to 0 and reboot. now, uninstalling the IR drivers in the device manager (if you have them) will work to enable the console to come up. if you don't have any IR drivers, then just doing the reg change should fix it for you.

It should also be noted that on the Windows7 platform, the console will not open due to compatibility issues. Bethesda may or may not be working on this problem in the form of a patch.

For window 7, another simple way to fix this problem is to prevent the OS to re-install the IR device at startup by renaming its drivers. To do that, search the files named hidir in C:\windows\inf\ , there should be two of them called hidir.sys and hidir.inf . Call them hidir.sys.bak and hidir.inf.bak Now go to device manager and uninstall the IR transceiver and ,when prompted to do so, reboot the system At the startup, window will tell you that it can't install the "new device" with a taskbar notification, this meaning that the trick worked. So now go to the device manager again and deactivate the "unknown device". finished :) tried it on my own system with win7 64 bits and still go fine for now. If you play Fallout 3 on PC with an Xbox controller you need to remove it from the USB port to access the console via keyboard.

You should try this first:

Tested and working method under Vista and Windows 7: This will work not only for Fallout 3, but all other games that use the "~" for console, AND lets you use your MS remote. This was an insta-fix for any laptop w/ a built-in detacheable remote. It also has less technical than registry entry edits, (and their eventual complications), and isn't nearly as sketchy as uninstalling and reinstalling the device/driver. A+ perma-fix for media centre comps/laptops.

Ring of Console fix

Follow the steps on the page to help activate the console. The page can be found at here. You must have the original ring of console as well. NOTE: This is only for users who CAN NOT under any circumstance open the console. Please try other solutions before resorting to this option, you might save yourself some time. This mod is in a beta, so use at your own risk. This mod works in the same way as the Ring of Console, and the item is gained after you escape from the vault.

Console Key Binder fix

An easier alternative to the Ring of Console fix would be the Console Key Binder mod, removing the hassle of equipping/unequipping an item. The file can be found here. This mod allows you to bind another key to open the console (default is F4) which is very useful if your tilde key does not work. Take note, however, that this mod requires Fallout Script Extender (FOSE). FOSE can be found here.

Microsoft eHome remote/receiver

If you use the Microsoft eHome remote/receiver (official media centre remote and USB receiver) you'll notice under your device manager you have a new device named Microsoft eHome MCIR 109 Keyboard; this is the cause of the tilde key not working. It also affects your plus, minus, parenthesis, hash, @, and slash keys remapping them to different functions. (some are even Kanji characters) NOTE: Many "ITECIR" (infrared) drivers under the device manager also cause the same issue. Solution is as follows and will not affect the functionality of your Media Centre remote: 1. Go into Device Manager -> Keyboards. 2. Right-click "Microsoft eHome MCIR 109 Keyboard", choose "Update Driver" ("Update Driver Software" on Vista). 3. Choose "Browse my computer for software" (XP users tell it not to install automatically and say you'll specify the location, then when it asks you where you would like it to search for drivers choose the option to choose from a list) then "Let me pick from a list of device drivers on my computer". 4. Make sure "show compatible hardware" is checked, then select "HID-compliant device" and click next. Click any remaining "OK" or "Finish" buttons after Windows has installed the driver.

AutoHotKey Fix

AutoHotkey is a free, open-source utility for Windows, used to remap keyboard or mouse buttons. If your "Tilde" (~) key isn't recognized in Fallout 3, one fix is to install AutoHotKey, and in the script used by the program, assign the "~" to another key. For example, to turn "F12" into a "~", use the line: F12::~ Now "F12" will be recognized as the command line button.   phoenix  txt  xp  11:33, March 17, 2010 (UTC)

This problem isn't limited to Fallout 3 and infrared drivers. "PC/AT Enhanced PS/2 Keyboard (101/102-Key)" and "Standard PS/2 Keyboard" are affected too. One way to fix this is to manually change the driver for that device to "Standard PS/2 101/102 Keyboard". See this DosBox thread for more info. -- 21:05, November 14, 2016 (UTC)

Accessing the Console With Non-English Keyboards

If you are using some keyboard layout other than English then the tilde key might not work or the keyboard may be missing it entirely. For example, I use an Apple Japanese keyboard and it has no key to the left of the "1" key, and the tilde key is with "^" on its own key. My solution was installing AutoHotKey and setting up a shortcut to send the exact tilde key code the game is expecting. You need to add these lines to your AutoHotKey script and it will map F12 to grave accent (`) and Shift+F12 to tilde (~). (The grave accent (`) key is the same physical key as tilde (~) on US English keyboards.)

; Map grave accent/tilde key (`/~)
F12::SendEvent {vkC0sc029}
+F12::SendEvent +{vkC0sc029}

Additional batch file examples

  • This batch file gives you a lot of ammunition, as well as some grenades and mines.
player.additem 0006B53C 90000
player.additem 000207F7 90000 
player.additem 0002937E 90000 
player.additem 00004241 90000 
player.additem 00078CC4 90000 
player.additem 00004240 90000 
player.additem 0006B53D 90000 
player.additem 000615A8 90000
player.additem 00029364 90000 
player.additem 0002935B 90000  
player.additem 00047419 90000 
player.additem 0002936E 90000 
player.additem 000615AF 90000 
player.additem 0006B53E 90000 
player.additem 00020772 90000 
player.additem 00078CC2 90000 
player.additem 00029371 90000
player.additem 00078CC1 90000 
player.additem 0006A80D 90000 
player.additem 00078CC3 90000 
player.additem 00004485 90000 
player.additem 00020799 90000 
player.additem 000B8791 90000
player.additem 0005F706 90000
player.additem 00078CC5 90000 
player.additem 00029383 90000
player.additem 00029384 90000
player.additem 00028EEA 90000
player.additem 0004C5F9 90000
player.additem 00056634 90000
player.additem 00004342 20 
player.additem 0000433A 20 
player.additem 00004330 20
player.additem 0000433C 20
player.additem 0000433D 20
player.additem 00004331 20
player.additem 0000433E 20
  • To find all the positions of a selected object (x position, y position, z position; x angle, y angle, z angle) all at once you can use the bat command with a text file containing the getpos and getangle commands. To execute the command, you would type bat pos
GetPos X
GetPos y 
GetPos z
GetAngle x
GetAngle y
GetAngle z
  • This batch shows the most relevant information about NPCs and enemies. Select a NPC or enemy and type bat info
getav Health
getav DamageResist
getav SmallGuns 
getav EnergyWeapons
getav BigGuns 
getav Explosives 
getav MeleeWeapons
getav Unarmed

iConsoleText in Fallout.ini

The position of console text can be set in the Fallout.ini file. In Windows XP at:

C:\Documents and Settings\<username>\My Documents\My Games\Fallout3\FALLOUT.INI

For Vista and Windows 7:

C:\Users\<username>\Documents\My Games\Fallout3\Fallout.ini

First right-click the file, select Properties, then uncheck the Read-only attribute. Now open the file in a text editor like Notepad. Search for "iConsoleText",in the "[Menu]" section.

  • Set iConsoleTextXPos to 200 or so. Higher figures move console text to the right. This is the main problem.
  • IConsoleTextYPos should be approx. 100 or 200 less than your Y resolution. Lower figure moves it up (0 is the top of the screen).

An example for a 1280x1024 (XxY) 5:4 display:

Setting            Default  New Setting  Notes
iConsoleTextYPos     940        900      Y (up/down) pos is 100-200 less than your Y res (here, 1024)
iConsoleTextXPos      30        200      X (left/right) position is higher (which moves it to the right)

After you finished modifying the file accordingly, re-enable the Read-only attribute as well as the Hidden checkbox in order to prevent the Game from overwriting it.


The videos are unavailable for me, it says "contains copyrighted material of Sony Music and has therefore been deleted for your country" (which is Germany in my case). Could someone check if that's the case for other countries? If the videos have been made unavailable for most people worldwide (I'm uncertain about Youtube's deletion policies, which are debatable anyhow, but that's another issue), then the links could IMO be removed from the page. I just wished people would refrain from using some supposedly cool tunes that will cause only problems and are not helpful in any way but rather quite distracting in an educational video like this.-- 11:03, March 26, 2010 (UTC)

Direct console input possible ?

Does anybody know if its possible to submit consolecommands without opening the console ?

F.e. to submit "bat" commands via a macroprog.

Is there any "bypass console 'cvar" I didnt find so far ?

Thx in advance 01:49, May 25, 2010 (UTC)Old Dirtbag93.83.225.138 01:49, May 25, 2010 (UTC)

is there some kind of bind command?-- 13:58, December 30, 2011 (UTC)


Hi just wanted to know how to unset ownership once you have used setownership.

can`t figure it out

wastlander 01:33, June 1, 2010 (UTC)

How to replace "intense training" with another perk the correct way?

When leaving the vault 101 and leveling up i took "Intense Training" to lift up perception by +1 (from 6 to 7). After doing some stuff I decided it would have

been better taking Thief-Perk instead. So using the command "player.removeperk 44cb1" removed as awaited the Intense-Training-Perk from

my perk-list. I than added the Thief-perk via console. Looking at my values I saw that perception stayed at 7. So I had additonally to enter

"player.modav perception -1" to take 1 point away, which worked well.

When later taking the Intense Training perk by another levelup, I was NOT asked what S.P.E.C.I.A.L-attribute to increase ????

The perk was added to the list, but I got no additional point in a S.P.E.C.I.A.L because I was not asked?

So my question: What is to do, if I want to replace "Intense Training" by another perk without making a mess ?

I would have done it like you did as well. Then, when you took the intense trainging perk and didn't get the special screen, just modav to add a point to your choice, and the next time you take intense training, it should work normal. I am not an expert, so if someone else knows a better way, feel free to erase my answer.

Just an addendum to the answer, modav does not treat stat increases the same way as intense training, this is only relevant for endurance and the implant limit, just as a warning.

Key Bind

is there a code to bind a code to a key? You know just like in source games (bind x "noclip")--Richy8964 Disku Hilfe:Administratoren 20:39, June 26, 2010 (UTC)


Is there any commands I can do to make an NPC simply stand in place and not move? I've been trying to experiment with poses and screenshots, but the characters often just keep walking away. And using TFC 1 pauses them, but it also prevents me from changing their poses.—Preceding comment was unsigned. Please sign your posts with ~~~~!

I think SetRestrained might do that, but you also might need to just download the Groovatron mod instead of trying to wrangle the console commands to do it. --Kris mailbox

Weapon condition

Is there a command to stop weapon condition going down but your health, ammo usuage, etc. do still go down, basicly god mode only for weapon condition. - RASICTalk 03:02, August 9, 2010 (UTC)

Try using Player.SetWeaponHealthPerc 100

It tops up your equipped weapon's condition to 100%


I've tried this and found it hard to notice any difference, but does changing the 100 to something higher, say 1000, change how many shots the gun can shoot? Or does it simply put it to 100%? - RASICTalk 00:47, August 13, 2010 (UTC)

Renaming Containers

On rivet city in the marketplace, left of the quick fix. i used it as a special weapons storage and i want to use the dumpster next to it as an ammunition bank. i already did the setownership console command. i just wonder if there is any way i can rename the thing.

Setname command should work.

Console in Fallout New Vegas

You don't need to modify the shortcut with " -console" to make the console wokr. I've try it without this modification and it works as usual (FNV UK).

Same here, works without having to modify the shortcut command. SpellChecker 05:53, November 5, 2010 (UTC)

Forcing an NPC to talk?

Hey there,

I encountered this one bug where you are attacked by the Securitrons inside the Lucky 38. In addition, Victor’s “corpse” lay in front of the building. After I returned a few days later and the “corpse” was gone I decided to try the solution mentioned in the Lucky 38 article and voilà, I was now able to get inside and to the Penthouse floor. I even talked to Jane who told me that Mr. House is waiting in his office but when I got there I only saw his face on the screen but could not talk to him. He didn’t talk to me either and pressing E) had no effect.

Does anyone know how to get him to talk? How is he supposed to behave anyway? And last but not least, is there perhaps a console command I could use for that? -- 17:20, October 30, 2010 (UTC)

10/31/10 I am working on this as well. There's 3 problems:

  • 1) Due to the vault 11 bug, the Lucky 38 securitrons are hostile. Solution: use "setally 1267AB 0001B2A4" (no quotes) in the console to reset their hostility.
  • 2) The bug causes quest "The House Always Wins" to fail. Solution: use "resetquest 147885" (no quotes) in the console to reactivate the quest.
  • 3) Mr. House still won't talk to you. Solution: Still working on it.

Ah, your comment is much appreciated. Though, as I wrote, I already knew of 1) and don’t think 2) applies to me as I can’t recall seeing the “Quest failed” display. But never mind, I’ll eagerly await your solution to this problem. I guess it won’t be as simple as using a console command to start a conversation with an NPC (if this exists)? -- 17:14, November 1, 2010 (UTC)

I appreciate your trying to help those of us affected by this bug. However, will using the console disable anything, such as Achievement progress? 19:28, November 2, 2010 (UTC)

The fix is:

setally 1267AB 0001B2A4 resetquest 00147885 setstage 00147885 5 setobjectivedisplayed 00147885 1 prid 001264c5 setdestroyed 0

the rfid above should be replaced with prid. rfid doesn't exist as a command
this was a really helpful answer in general. i hope you don't mind i edited your post to be more wiki-friendly because the list came up weird on my firefox (made a list) and changed the rfid. remember you can also actively select a refID by clicking on the object or actor or item with the console open in place of typing in their ID code. Marxismoney 08:04, December 10, 2010 (UTC)

Increase merchant cap limit

Is there a command that would increase the cap limit that merchants reset to every few days?

i found this annoying too... I just click on the merchant and type additem f 10000 = give the target X amount of caps i know...i know its silly since i could just click myself...meh -Forcedminer

do fallout new vegas work for fallout 3

do they

i'm assuming you mean the console codes? some of them do, some of them were added to new vegas for the new features. the ones pertaining to reputation obviously will not, because there was no reputation in FO3. try a google search Marxismoney 08:09, December 10, 2010 (UTC)

/* .INI Files */

added this section because i've found editing these files to be immensely helpful when using the console, but if it's already been said in the wiki, i apologize. feel free to move it around if you think it belongs somewhere else on the page. Marxismoney 08:00, December 10, 2010 (UTC)

looking back at the talk page it seems someone had already added some of the info i put in on here. if they want to edit my post, please go ahead.

how can you change a switch in the game by using ~? as im in the dam and to change the power and the switch i ment to switch doesnt work its marked out and on my quest but i cant switch it/doesnt show to switch any ideas? BTW this game is very buggy keeps ending my game for no reason(seems like a beta game)

I think that's the danger of putting a section like this up front of the page - people will start messing around with the INI files. Unless you want to really dig around for a solution, the best bet is to just keep it simple - if you don't need the pretty console with all the history, then there's no need to go changing the INIs. People's computers and setups are different. You've got to really read up on what you're doing with the game settings before you go switching them around for a quick fix. In this case, I'd suggest you just reload from a previous save, and if that fails, back up your saved games (find the folder they're in, should be the one with the INI files) and then do a clean install of the program. That should reset any bugs you're experiencing, and if it doesn't, then your save is corrupt and you need to reload from an even earlier one. Marxismoney 07:19, January 3, 2011 (UTC)


I just think it would be helpful for people to make sure they include the game which they're talking about in the subject line of their posts. That way people replying will not have to guess which game you have questions or suggestions about. Thx, Marxismoney 07:14, January 3, 2011 (UTC)

Fog of War

What exactly is "fog of war", and what does disabling it do? --Omny87 15:29, January 8, 2011 (UTC)

Fog of War is the places on the map you can't see when using the "Local Map", disabling it allows you to see an entire area as if it was already explored --Anonymous

New Vegas, through steam, bug?

So I bought New Vegas through Steam and it runs fine, but when i started using console commands to enable/disable god mode halfway through I stopped getting achievements. WTF is this? Anybody else have this? Is it fixable? What do I do? Please help! Ex1t Shark 18:38, January 20, 2011 (UTC)

I've got a similar problem and also running thru Steam. Used the "addperk" console command and the quest I was finishing remained "unfinished" despite completing all the objectives. The command is definitely the cause because I tested it from a prior save-point before entering any commands, and the quest completed.
Nightowl12 10:26, January 21, 2011 (UTC)
Of course you aren't going to get an achievement; you aren't playing fairly. In order for achievements to mean anything, they have to be earned without cheating(console commands). - CrazyMunky (not a user here yet.)
In case someone reads this later on...the way to get your achievements is to use whatever cheat you want to use (such as player.srm), then save, exit the game completely and restart and continue. The "cheat" tracking starts at each complete restart, so just always restart after each ~ set of commands. Pharmboy 19:21, October 18, 2011 (UTC)

[F:NV] Console commands for challenges?

Anyone with this family of commands? Basically it's kind of idiot, but I would like to reset/modify some challenge counters, are there any command line about it? --Niflheimr 09:55, February 4, 2011 (UTC)

  • Yeah, use: incrementscriptedchallenge <base ID>. Example, for one point in "All for One" (which will finish it, as it is 1/1) incrementscriptedchallenge XX011f34 KaisarDragon 19:03, October 23, 2011 (UTC)

Fallout 3 Quest objective ID reset help

I made a mistake and talked to the Dr. in Rivit city before going to find Three Dog. Once I spoke to the Dr. the Following in his footsteps quest (quest id - 00014e87) was marked complete and subsequently grayed out. I'm trying to find a way to reset the quest to the point I was at so I can continue on (finding the Dr. when I'm supposed to). I've managed to figure out how to reset the quest to objective level 210 using "setstage <base id> <Quest Objective>" but I'm not sure what objective 210 is. Can anyone point me in the direction of an objective list for this quest that is more description and less unhelpful number? Also when I run the sqv command I saw that the quest was not "running" so I ran "startquest (id)" but even though the quest now shows as running (with a sqv) the quest is still grayed out and marked complete in the pipboy in game. If someone could straighten me out I'd be more then gratious. Please be kind as i'm a total noob with these commands.

Thanks so much in advance! 08:50, February 9, 2011 (UTC)Ryme


Are notes themselves treated as items? So far trying to delete one (Toike Blackmail Note) has not worked for me. 14:33, February 13, 2011 (UTC)Fitzy

Add Perk glitch

Encountered a glitch which wasnt present before

Every time I try to add a new perk to my character, the console command works but the added perk doesnt show up in pipboy and neither is it working

However all other commands work just fine, everything except addperk

I have not seen this particular problem being posted or I sort of missed it while reading through the list

Any solutions or idea what's going on?


What are the exact command lines that you are typing into the console? --HunterZ 19:08, May 16, 2011 (UTC)
I'm having the exact same issue the problem IS NOT WITH THE COMMAND line, I'd type in player.addperk 146096 and it say travel light added to Jack but when checking my pipboy the perk wouldn't be there or the effects. Strangly if I add a perk from a DLC it adds fine.-- 04:09, October 3, 2012 (UTC)


for what systems can this be done with i have fallout 3 for xbox360 and it dosnt say anything for use on other gaming systems

As mentioned at the very beginning of the article, console commands can only be used in the PC version (as far as I know anyways). --HunterZ 19:08, May 16, 2011 (UTC)

Console command to show the FPS in game ?

I've searching for this console command but was unable to find how tu show the current frame per second on screen. Anyone could tell me the console command to do this ?

I'm not aware of a console command to do this, but you can always use Fraps or some other external program to show the FPS. --User:HunterZ(talk) 00:15, May 28, 2011 (UTC)

Hey lads, added a little tutorial.

Hello. I added a little tutorial for those who can't get the GECK to work on their computer, or any other reason. I always hated the fact that I fail at the GECK, so I have decided to help others who have the same problem.

The tutorial goes as following:

Building Houses Without GECK

  • If you don't know whow the GECK works, here is a little tutorial on how to create a player home without it.
    • First of all, you will need FOSE, or NVSE.
    • Now, using the Developer Console, you can delete, spawn, change alot of things in Fallout.
    • For an example, go to the Goodsprings Schoolhouse. That place is a mess.
    • The trash on the floor gives the room a messy look. Try to open the console, target it and type in: Disable to get rid of it.
    • If you miss, do not close the console. You must type Enable. Note that this is neccesary if you accidently remove the floor beneath you, so be careful.
    • So now you have removed one of the trash details... there are still many to go. But for now, 'disable' all the tables in the room.
    • When you got rid of them, the trash are still here. Always remember to quick-save before you delete something.
    • Delete the trash on the floor, to make it look more clean. Note that you must be precise when targeting the trash.
    • Great! You have now cleaned your room faster than ever. You're mom would be so proud. Now: To decoration.
    • It's here where Script Extender comes into the picture. Using the command GBO, you can get the base ID of an entity.
    • There are plenty of lockers inthe schoolhouse. Delete some of them, but keep alteast one.
    • When you are done, target the locker and type the GBO command.
    • This will print the Base ID into your console. Find a good spot where you want to palce your locker.
    • Let's say the base ID is 00420106 (random number), you must now type in the line: 'player.placeatme 00420106'
    • Note: You must be standing where you want the locker to spawn. You must center your Line of Fire to 90 degrees.
    • Note: If you look up while spawning the locker, the locker will spawn sideways, making it look odd and misplaced.
    • If it's a minor mistake, like 89/90 degrees, you can use the Rotate command.
    • Congratulations! You have now learned alot more about the console! Have fun!

If you find any mistakes, violent content, etc etc... Please fix it. I only want to help.

--Jo-Barf Creepy 15:51, July 23, 2011 (UTC)

This would be great for a forum post. --Kris User Hola.jpg 15:47, July 23, 2011 (UTC)

Ow... Didn't think of that --Jo-Barf Creepy 15:53, July 23, 2011 (UTC)

Reputation and Special altering commands not working

I have tried changing my reputation with the powder gangers to access some of their quests and also to finish the quest for Primm's deputy since I am vilified with them I cant do any of that, upon trying out all the reputation altering commands I managed to change my reputation to Idolized just to see if this actually works, but upon fast travelling to the NCRCF I was still being attacked even though I am Idolized, I also tried sleeping for 4 days as some users suggested in other posts but nothing changed and I was still being attacked. More recently I was trying to alter my SPECIAL attributes via the console using the "player.modav" command, more precisely the endurance attribute to be able to receive multiple implants, and seeing as my initial endurance level was 1 I could only get 1 implant but despite the fact that I modified my endurance all the way to 10 I was still unable to get more than 1 implant, In conclusion I am suspecting that even though the change is visible when using the commands there is no actual effect which should take place, or perhaps the npc's do not react to the console commands, I am playing on very hard with hardcore enabled if this has to do with anything. Any help please?-- 14:03, August 15, 2011 (UTC)Anonymous

Setname Command not Working

All the console commands tried work except for setname "NAME", with the game telling me it doesn't recognize the command setname (command "setname" not found). What could be the problem?

Only Mod installed is a lucky 38 suite enhancher, with no other mods required or extra. 12:39, September 22, 2011 (UTC) A.V.

Formatting command lists

While cleaning up a couple of command entries, I noticed some of the commands





while some others

  • are
  • formatted
  • this
  • way.

Personally, I think the bulleted list looks better but don't feel strongly about it. Does anyone else have an opinion?

Regardless of which way we decide to do it, they should be consistent and I will be fixing that after a little time for interested parties to comment.

Thanks! UncleBubba 15:58, September 25, 2011 (UTC)

Getting rid of NPCs?

So, when I click on an NPC (living or dead) and type "disable" into the console... nothing happens. No error message or anything... just... nothing. Works just fine on random objects, though. Any idea of how to get rid of NPCs? Is there another way to do it?

You might get more/better responses if you post a question in the Forum. I'm sorry, but I don't have an answer for you. UncleBubba 23:19, September 25, 2011 (UTC)

Problem with FalloutPrefs.ini

In my second playthrough I thought about testing some cheats. But the console doesn't show up! I've looked for all bAllowConsole=1 (they're okay) and iConsoleTextXPos <- There is the problem. In all three Ini.s I changed this line to iConsoleTextXPos=200 BUT in my FalloutPrefs it doesn't change! It's not read only.

I can save it changed, but If i start the game FalloutPrefs set back to 30. Whats wrong?

EDIT: I found a second FalloutPrefs.ini in the main game folder. If I delete this or the other file, it spwans again.

- Mirabelle

anyone knows exactly how healrate in fo3 works? in the wiki it is explained for other version but fo3. i have tested it a bit, I found a wounded scavenger, and wrote setav healrate 999, and he starts to regenerate hp slowly. thats how it works, but I thought 999 is quite a big number, and normally the npcs such as scavenger don't have so many hp, do they? Tried some more, setav healrate 999999 will make npc regain health very fast in combat, as long as the enemy's attack is not strong enough to take out one in a single blow, npc will regain health in 1 or 2 seconds and keep fighting, but healrate doesn't heal limbs, so the npcs can have full health and every part of the body crippled at the same time. 16:42, October 4, 2011 (UTC)

I play fallout 3.I have a problem,i am naturl but talon and regulator come after me ,i want use console command to setally as friends ,but i have no factions id

What is the command to drop an item out of your invetory? -- 23:15, April 27, 2012 (UTC)

Is there a way to undo "setav" on NV?

I used "setav carryweight 1000" on my character and now when i restored it to the original value i doesn't change when i use STR boosting items like Beer, Buffout etc. Is a way to restore the formula? 13:48, September 21, 2012 (UTC)


I tried using the command to set an NPC as a follower, however every time I fast travel or enter a building the NPC is no longer my follower. Is there any way I can fix this

Steam Achievements

The page says if you open the console steam achievements are canceled until you restart the game. What happens if you use the console to cheat in an item, restart the game, and try to get an achievement? RexMan85 (talk) 09:13, July 30, 2013 (UTC)

Information Not Complete?

How can this page not contain completed information after like... 7 years!? I had to add "damageactorvalue", and I think a few more are missing. I noticed a lot of pages on this wiki are being merged, but if they don't even use completed information when the Gamebryo engine isn't Bethesda's current engine anymore, what's the point?

Also, what is with the pages being merged not having capitalized titles? It just looks sloppy and unprofessional. Ulithium Dragon (talk) 23:04, October 31, 2013 (UTC)

EDIT: I see now that this page isn't supposed to have all the commands, as evident by the link at top to the (all) page. If you admins are so intent on merging pages, why does this page even exist? Except for a small amount of documentation on some of the commands, the pages are virtually identical, except this one doesn't have all the commands. It would be easy enough to edit the table format on the (all) page to add a explanation section. Ulithium Dragon (talk) 23:10, October 31, 2013 (UTC)

Can I unhide the hidden items on the Pip-Boy 3000 ?


I was just wondering if I could unhide hidden items on the Pip-Boy 3000 the same way I can unmark as quest items the quest items with the command "setquestobject <itemsbaseid> 0" ?

I'm thinking about something like "sethiddenitem 00140c39 0" to unhide the 1st Recon assault armor, of course.

Thanks. 18:41, December 2, 2013 (UTC)

Reset single NPC dialogue - possible??

So there's that command "rdf" which resets the dialog trees of all NPCs in the game. But I think it's much more interesting to know, if there's a way to reset the dialog of just one single NPC. I really need to know for a bugging quest I have. Thanks for answers.

Is there an "ECHO OFF" equivalent?

CLS works just like it would in DOS or a Windows command line window, and semicolons are like putting REM before a line in a .BAT or .CMD file, and I now know SCOF works like when you run any command followed by " > FILEOUTPUT.TXT" OK cool. So is there a way to make Gamebryo batch files (for lack of a better term) work so they don't display commands being entered?

For example, if you make a batch file that says

prid 14

getav charisma

you'll see this:

> PRID 14
> getav charisma

In DOS and Windows BAT/CMD files, you can enter "ECHO OFF" [1] in the first line and the screen will only display the results of the commands, not the commands themselves. In the above example, only "GetActorValue:Charisma>>7.00" would be shown. That way you could, say, run a batch with a list of GETAV's and the results would all fit within the wee 15 lines of display within the game's command line interface. There's gotta be something. Noobyorkcity (talk) 23:27, June 26, 2014 (UTC)

Console History

THe page says

"This is an extremely helpful function if you've extended the console's history in the .INI files, and especially useful with the console command help, which will display a list of all possible console commands (requires a good deal of reading). You can only see the entire list if you've increased the iConsoleHistory value to higher than the factory settings."

This is confusing. If I use command help, I get only the last 15 results. You cannot see the entire list by increasing history size. that only stores more previous commands?. you need iConsoleVisibleLines=XX to do increase the list of results. I used that command and set it to 200 What I CANNOT find, is how to scroll the RESULTS of a command, not the HISTORY of the commands. page up and down doesnt work, neither does up or down arrow.

so consequently I get the FIRST 25 lines and no more..and when I type something in, I dont see it on screen..because its 'hidden' at the end of the (200 line) list. I want to know how I display the next 25 lines and so I said page up and down doesnt work, nor does up or down arrow. THanks 20:40, July 8, 2014 (UTC)

PageUp/PageDown dood :) 20:28, October 13, 2014 (UTC)

The numpad PgUp/PgDn keys will not work -- you have to use the regular keys above the arrows. If you're on a laptop, it's possible the keyboard is sending NumPgUp rather than PgUp. If so, you'd need to plug in a standard keyboard and use it. It's also possible to use something like AutoHotKey to spoof the correct key, but I don't have any experience with it.

Also, if you changed iVisibleLines to 200, the list would extend off the screen. For the first several commands, all the lines would be on one console screen, while being off the edge of the physical screen, so paging would do nothing. Set your iVisibleLines back to 15 or something, set your iConsoleHistory to 200 or something, then try paging. 08:58, June 9, 2015 (UTC)

Timescale and crashes

What is the source of this information and has anyone ever tested to see if it's accurate? "Warning: Altering the timescale will cause the game to crash if NPCs spawned using placeleveledactoratme or movetoplayer enter into combat." --Rooker75 (talk) 16:01, November 18, 2015 (UTC)

Community content is available under CC-BY-SA unless otherwise noted.