Hey, since its a picture of power armor vault boy, and its called "Death From above", maybe you either are in Vertiberds, or come from a air vehicle, or maybe even ARTILLERY unit--Eustas P. Vanderbanger III 01:57, 20 April 2009 (UTC)

Or the Citadel is bombed out from "above", since the DLC is called BROKEN Steel :D 10:53, 20 April 2009 (UTC)

That could be true, but i am a die-hard ultra mega BoS fan......BOTHERHOOD FTW!!!1!!!!!ELEVEN!!!!
FFS, the picture is of those SatCom arrays scattered throughout the wasteland. The BoS will get the satellite bombardment <3 That Furry Bastard 13:00, 20 April 2009 (UTC)
Grizzly can smile?! Nitty 01:36, September 21, 2009 (UTC)

this probly refers to the fact that u have to many brotherhood solgers dying from v birds and now you have to go find a tesla coil to create the weapon that takes a v bird down in one shoot this probly refers to the mission shock vaule

Retrieved from ""

Actualy the picture you're talking about is for the quest "Who Dares Wins" not this one. I don't know why it would be called "Death From Above". I suppose the most obvious thing would be a vertibird bombardment, but that would be slightly unfair since it would only take one to kill you lol.--Greig91 19:30, 29 April 2009 (UTC)

Well, looking at the trailer for Broken Steel, it would seem that the "Death From Above" is an orbital bombardment, since we see in one scene what appear to be missiles falling from the sky, and Liberty Prime ordering everyone to a safe distance. Wanderer Lao 03:58, 4 May 2009 (UTC)

Call of Duty 4 Mission

Could this be named after the Call of Duty 4: Modern Warfare mission entitled "Death from Above"? -- 04:32, 23 April 2009 (UTC) WTF no.

Why would you even think that? Death from Above is a very common term in the gaming world, so no they don't have to have stolen it from another game, they could come up with it all on their own. 17:02, 23 April 2009 (UTC)Cavesloth

Not only is it a common term the gaming world, but the English language in general. "Death from Above" goes all the way back to American paratrooper divisions in WWII. ~ Unsigned 4 May 2009


I received 1690 XP when I completed the mission. I was just a little bit over lvl 21. Is the reward based on current xp? EugeneT 00:27, 6 May 2009 (UTC)

It shouldn't be, you probably have some ranks of swift lerner + the 'well rested' bonus. You should confirm this so the rest could know for sure.
A 40% bounus from 3 ranks of Swift Learner and Well Rested should net 1680 XP. I'm not sure where you're getting the other 10 XP. --Bloodscar 00:52, 25 July 2009 (UTC)

Frank Horrigan Reference

Is it just me, or is Liberty Prime's death sequence a whole lot like that of Frank Horrigan in Fallout 2? They both get sliced in half, they both try and crawl away, and both their heads seem to jeteson off. You can even talk to Liberty Prime, just like you could talk to Horrigan when he was dead. I don't know, that's the first thing I thought.


Well, when i try to get into the car tunnel the gate says that you need a key to go through. well, i said, no problem, "tcl" and through. but the door with a BoS in front also needs a key, is there a key or did I get owned?

I have the feeling I'm getting screwed as well. I did as suggested in the article, go back to Scribe and talk with him again. Nothing happens. Nothing to be found on Google either. -- 09:02, September 20, 2009 (UTC)ab

Same issue happened to me; article suggestion did not help. I had to use resetquest in the console, then start over (fortunately it isn't much to start over from; just go back to Lyons again, then to Rothchild again). -- 01:29, September 21, 2009 (UTC)

A small bug...

After i finish "Take it back!", watch the ending scene, and wake up 2 weeks later, i am unable to move, furthermore i am UNDER the medical table in the citadel, with the Camera shake animation from when u drop after activating the purifier with 216 code, on a loop. TCL does nothing, if i move using "Player.moveto Owyn Lyons" in the console (or to any other npc), the same situation but in a different setting, im on the floor, unable to move or do anything, with the squirming animation in loop. Is there anyway to fix this? or does anyone else have this bug? Please help. ill be watching this page. Thx in advance.

EDIT: Installing patch 1.5 fixed it, Special thanks to Slippet on Fallout Wiki IRC Channel.

A strange bug

I went to the relay station with Fawkes. He stopped with the BoS guys to the first room and didn't follow me. However, if there were a battle near them, they would join it. I took care of the Enclave myself and downloaded the data from the terminal. When I try to leave the building (top or bottom door) the loading screen appears and after the two pages the background just goes black. It takes a long time and doesn't seem to really load. Maybe it just crashes there. I have PS3 with Broken Steel and The Pitt add-ons.

EDIT: oh, it seems to be a feature ( I should be more patient

Companion Advice

I'd like to add something to the article. This is the only DLC that companions can follow you. But it's a pretty bad idea to bring them along on this mission, since the missile strike is almost sure to kill any of your companions!!! dusty_duster 16:43, October 19, 2009 (UTC)

Hugh Cash

Don't forget to look on the bodies of the dead Enclave soldiers. The plasma rifles are around 250 caps each and the laser rifles are sometimes worth as much as 500 caps apiece! Since each fallen enclave soldier has either a plasma or laser rifle (sometimes both) and they're 8 wg each, I think it's a good idea to only bring the gear you absolutely need so you can maximize the profit$.

-And seeing as huge useless money is in Fallout 3, one wonders WHY. Even on Very Hard, you're always gonna have a huge surplus of cash that you don't know what to do with.

Strange Objective Arrow

After Prime's demise and before entering the hole he punched into the wall I looted the area but upon returning to the wasteland i have an objective pointing at a place near Springvale School to its NE across the river. There's a junction in the line in the river just SE of the arrow. Anybody else get this? The arrow doesnt show on the direction bar like normal ones do, just on the world map. At first i thought it might be a hidden treat but it doesnt seem so. 21:27, January 23, 2010 (UTC)

moved from article

  • When fighting Enclave soldier's inside Satellite Relay Station,after some of fighting has stopped sending home Dogmeat (maybe even a follower)may cause Brotherhood of Steel soldier's to relentlessly attack them.This happened when I went in with Fawkes and Dogmeat on Xbox360.Dogmeat can be sent back to Vault 101 safely by going back outside the facility.

this is in first person and is unconfirmedKatikar 15:45, February 15, 2010 (UTC)

Game-Breaking Bug

Whenever I wake up from the coma, Elder Lyons never comes in. He opens the door and then walks away. I stay in controlless mode, keeping me from pursuing him. Using console commands, I spawned a copy of him, but that didn't work. If anyone has a solution, please tell me. PepterPepper 16:51, February 28, 2010 (UTC)

The BOS Knights

The knights inside the car tunnel keep on endlessly coming in. If youw ait long enough. You will see 1 leave and 1 more come in. Endless amount of holotags, anyone? Please confirm

Lots of Armor

I ran this quest but didn't get the codes and exited. I traveled back to the entrance, dropped off all the armor and plasma rifles i had (and fawkes had) then ran thru again. A lot of the enclave respawned in a very short time so I left with another 5 tesla armors and a dozen plasmas before I got the codes.

Achievement Bug

Ok as it mentions on the normal page for Death From Above, a glitch can occur upon completing this where it awards you the achievement but your gamerscore will not display the added points. In my case it was slightly different, I got the points and everything like I should but upon viewing my list of games (and their list of achievements i.e. 70/72) it was saying I was missing 2 achievements from FO3 but upon going into FO3 directly it showed me as having 72/72.

At the time I had zero idea what the issue could be, but recently I was at a friends house and recovered my gamertag. Upon going through to see if I lost any achievements, FO3 was "fixed" and displayed 70/72 and showed me missing this achievement and "Shock Value" achievement. Figured Id post the info here so if the same thing has happened to other people they know of one possible fix to try.Skitz470 05:22, March 31, 2011 (UTC)

Frozen NPC Bug

At one point somewhat towards the middle when going through the satellite relay building, all followers just stopped and wouldn't follow me. The enemies that came up later would also not move and would shoot in place. When I got to the end and tried to go out the door, the game sits and loads forever eventually going to a black bg with the stats over it. I also backtracked and tried to leave the way I came in and it does the same thing. I backtracked and it eventually let me out of the area. Strange stuff. Gary 42 00:11, May 21, 2011 (UTC)

Lyons Bug

Just played through this whole quest, gave the data to the scribe whom in turn told me to talk to Lyons, and now his map marker is southwest of Bigtown, and when I go there he is nowhere to be found. The marker points to The Citadel, and when I enter it points to the aforementioned location. So technically he is inside The Citadel, but near Bigtown. How in the world can i fix this? I am on Xbox. Caseysbrother 07:43, August 12, 2011 (UTC)

Possible Reference

Im not adding it as I think its far too tenuous, but Death from Above is the tattoo that Rico and the other starship troopers get before they first go to war, this could be a reference.--MrSuperHappy 21:13, November 27, 2011 (UTC)

Community content is available under CC-BY-SA unless otherwise noted.

Fandom may earn an affiliate commission on sales made from links on this page.

Stream the best stories.

Fandom may earn an affiliate commission on sales made from links on this page.

Get Disney+