This talk page is only for discussing improvements to the page "A Model Citizen."
Icon talkpage.png

Overseer Desk Glitch

During this quest I have encountered a potential bug when placing the Overseer desk from the special menu into play. Normally this results in dialogue from Overseer Barstow. However nothing happens. I have tried moving it multiple times, reloading my saves fast traveling. I have seen multiple reports on this bug. I play on Xbox one with a modded save. This may occur on Pc as well since I have seen this talked about on the steam forums I may try playing with an unmodded version and another character that is modded to see if I get the same results --Spongeboy1985 (talk) 01:08, July 27, 2016 (UTC)

UPDATE:My unmodded save worked. I decided to downsize on some of my mods and the same character savefile (modded) worked as well. It's possible it could have been mod related or simply the state of my game save. --Spongeboy1985 (talk) 03:47, July 27, 2016 (UTC)

Community content is available under CC-BY-SA unless otherwise noted.